Narzędzia użytkownika

Narzędzia witryny


Pasek boczny

sk1:vlan

VLAN

Materiały o VLANach

Topologia fizyczna sieci – urządzenia i połączenia między nimi

W ramach fizycznej topologii można tworzyć sieci wirtualne – VLANy.

Przykładowo firmową sieć (fizyczną) można podzielić na sieci:

  • dla pracowników – serwer domeny AD i komputery pracowników
  • dla działu administracji (księgowość, płace, etc.) – serwery baz danych i komputery pracowników
  • służącą do zarządzania siecią – dostęp do konfiguracji urządzeń sieciowych
  • bezprzewodowe punkty dostępowe dla gości

Typowo do budowy sieci VLAN używa się zarządzanych przełączników, a ruch z sieci wirtualnych trafia na router (i firewall) który decyduje o trasowaniu do/z internetu jak i między VLANami.

Sieci VLAN są identyfikowane przez numer (VID) z zakresu 1÷4094.
CISCO i VLAN nr 1

Zalety sieci VLAN:

  • możliwość zmiany "fizycznej" topologii sieci bez zmiany sprzętu
  • separacja urządzeń
  • ograniczanie ruchu rozgłoszeniowego

Łączenie switchy użwających VLAN ze sobą

  • "naiwne" łączenie
  • trunk / vlan tagging / 802.1Q
    • native vlan

Konfiguracja switchy CISCO

Konfiguracja przełączników (switchy) CISCO:

  • tryb użytkownika >
    • enable – wejście w tryb uprzywilejowany
  • tryb uprzywilejowany #
    • configure terminal (conf t) – wejście w tryb konfiguracji
    • show vlan [brief] (sh vlan [br]) – pokazanie konfiguracji vlanów
    • show interfaces trunk – pokazanie aktywnych połączeń typu trunk
  • tryb konfiguracji (config)#
    • vlan <nr_vlana> – wejście w konfigurację sieci vlan
      • name <nazwa> – nazwanie vlana
    • interface <nazwa_interfejsu> – konfiguracja interfejsu, np.
      interface FastEthernet 0/1 (interface Fa0/1)
    • interface range <lista interfejsów> – konfiguracja wielu interfejsów naraz, np.
      interface range FastEthernet 0/1-5, FastEthernet 0/11-15
  • tryb konfiguracji interfejsu (config-if)#
    • switchport access vlan <nr_vlana> – dołącza port do wybranego vlanu, np.
      switchport access vlan 5
    • switchport mode access – ustawia port by nie był trunkiem
    • switchport trunk encapsulation dot1q – ustawia by używać standardu kropka 1 q, czyli 802.1Q, do połączeń typu trunk na tym porcie
    • switchport mode trunk – ustawia port by był trunkiem

VLAN a STP – MSTP i pomysły CSICO

Przykład konfiguracji i diagnostyki switchy CISCO:

Konfiguracja na Linuksie

VLAN w Linuksie:

  • ip -d l wyświetlanie list interfejsów z detalami (pełne polecenie: ip --detail link show)
  • ip l add link <nazwa_nadinterfejsu> <nazwa_nowego_interfejsu> type vlan id <numer_vlan>
    dodanie interfejsu reprezentującego vlan, np:
    ip l add link eth0 eth0.2 type vlan id 2
  • ip l del <nazwa> usunięcie interfejsu

Przykład konfiguracji routera na Linuksie:

Konfiguracja routerów CISCO

  • tryb konfiguracji (config)#
    • interface <nazwa_interfejsu>.<numer_podinterfejsu> – konfiguracja podinterfejsu, np.
      interface FastEthernet 0/1.5 (skracając: interface Fa0/1.5)
  • tryb konfiguracji podinterfejsu (config-subif)#
    • encapsulation dot1Q <numer_vlana> – przypisanie interfejsu do sieci vlan, np:
      encapsulation dot1Q 5
    • ip address <adres> <maska>
  • tryb konfiguracji interfejsu (config-if)#
    • no shut– żeby podinterfejs działał, trzeba włączyć cały interfejs

Przykładowa konfiguracja routera CISCO:

sk1/vlan.txt · ostatnio zmienione: 2019/05/09 17:29 przez jkonczak