Narzędzia użytkownika

Narzędzia witryny


Pasek boczny

sk1:cisco_ospf

OSPF

Wstęp

Protokół stanu łącza (wewnątrz obszaru)

OSPF w wersji 2 działa tylko na IPv4, w wersji wersja 3 też na IPv6.

Każdy router konstruuje mapę sieci. Używa algorytmu dijkstry dla znajdowania najkrótszych ścieżek.

LSA

Link-State Advertisement (LSA) to pojedyncza jednostka informacji o sieci używana przez OSPF http://en.wikipedia.org/wiki/Link-state_advertisement
Przykładowo LSA może nieść informację o:

  • połączeniach wybranego routera OSPF z innymi routerami OSPF
  • sieciach IP do których należy router
  • o trasach z innego obszaru
  • trasach spoza OSPF

Działanie

Routery, wymieniając wiadomości Hello, nawiązują relację z sąsiadami.

Następnie przesyłają wzajemnie w wiadomościach database descriptions (DD) informacje jakie znają połączenia, routery etc. (tylko ID wszystkich znanych LSA).

Po transferze żądają nieznanych sobie wiadomości (LSA) wysyłając komunikat Link-State Request i otrzymują odpowiedź we wiadomościach Link-State Update.

Po każdej wykrytej zmianie router wysyła komunikat LSU z opisem zmian (LSA). Komunikat LSU jest rozgłaszana epidemicznie do wszystkich sąsiadów.

Żeby zapobiec zalewaniu sieci pakietami protokołu OSPF, w jednej domenie rozgłoszeniowej wybiera się router desygnowany i zapasowy router desygnowany (DR i DRother w CISCO) i dopuszcza się tylko komunikację do / z routera desygnowanego.

OSPF do odróżniania routerów wykorzystuje identyfikator routera - w CISCO to domyślnie najwyższy przypisany do urządzenia adres IP. Na router desygnowany wybierany jest router z najniższym priorytetem, jeśli priorytety są równe (a domyślnie są) - z najmniejszym identyfikatorem.

Adresy używane przez OSPF

OSPF w miarę możliwości (technicznych sieci) używa IP-multicast, wykorzystując dwa adresy:

  • 224.0.0.5 - wszystkie routery - All OSPF Routers
  • 224.0.0.6 - desygnowane routery - All DRouters

Przy konfiguracji OSPF pozwala podzielić sieć na obszary (areas). Routing w każdym obszarze jest wykonywany osobno, wykorzystując algorytm Dijkstry, między obszarami wymieniane są gotowe trasy. Obszar 0 (area 0) stanowi szkielet (backbone), wszystkie inne obszary muszą mieć z nim łączność. Router łączący dwa obszary nazywa się area border router (ABR).

http://en.wikipedia.org/wiki/Open_Shortest_Path_First

http://technet.microsoft.com/en-us/library/cc940481.aspx

Slajdy (wbrew tytułowi zawierają też informacje dla routerów CISCO)

OSPF na routerach CISCO

Konfiguracja

Najpierw należy wejść do trybu konfiguracji (znak zachęty: (config)#).

  • router ospf <processId> - wejście do konfiguracji procesu OSPF o podanym numerze.
    Numer procesu jest lokalny - stąd można wybrać dowolny, np: router ospf 1. Prompt zmieni się na (config-router)#
    • network <adres_ip> <odwrócona_maska> area <obszar> - dodaje sieci pasujące do wzorca do rozgłaszanych sieci oraz aktywuje na nich wymianę komunikatów OSPF. Dodanie pierwszej sieci włącza proces OSPF.
      Przykład: do dodania sieci 192.168.0.0/24 do obszaru 0 należy wpisać:
      network 192.168.0.0 0.0.0.255 area 0
      Można też podać "cały świat", który dopasuje się do każdej bezpośrednio podłączonej sieci:
      network 0.0.0.0 255.255.255.255 area 0
    • auto-cost reference-bandwidth <prędkość_w_Mbps> – ustawia referencyjną prędkość używaną do automatycznego obliczania kosztów połączenia, np:
      auto-cost reference-bandwidth 1000
    • default-information originate - włącza redystrybucję trasy domyślnej
    • redistribute <co rozgłaszać> - włącza rozgłaszanie tras podanego typu - połączonych, statycznych lub z innego procesu/protokołu routingu. Uwaga: nie włącza OSPF na pasujących sieciach – tylko dodaje je do rozgłaszanych. Np:
      redistribute connected subnets - wszystkie bezpośrednio podłączone sieci
      redistribute static subnets - wszystkie trasy statyczne
      redistribute eigrp subnets - wszystkie trasy dostarczone przez protokół eigrp
    • passive-interface <interfejs>|default – wyłącza nawiązywanie połączeń OSPF na wybranym interfejsie, lub domyślnie na wszystkich interfejsach.
      Przykład 1 – wyłącza wysyłanie i odbiór OSPF Hello na interfejsie FastEthernet 0/0:
      passive-interface FastEthernet 0/0
      Przykład 2 - pozwala na połączenia OSPF tylko na Serial 0/2/0-1
      passive-interface default
      no passive-interface Serial/0/2/0
      no passive-interface Serial/0/2/1

W trybie konfiguracji interface'u można ręcznie ustalić koszt łącza:

  • bandwidth <prędkość> - zmiana postrzeganej przez protokoły routingu prędkości
  • ip ospf cost <koszt> - sztuczna zmiana kosztu danego łącza dla OSPF

Diagnostyka

W trybie uprzywilejowanym:

  • show ip protocols
  • show ip ospf - informacje o działających procesach ospf
  • show ip ospf interface - informacje o stanie OSPF na interfejsach - koszt, sąsiedzi, lokalny identyfikator etc.
  • show ip ospf neighbor - informacje o sąsiadach
  • show ip ospf database - podsumowane dane o połączeniach
  • show ip ospf database network - podsumowane dane o sieciach łączących routery OSPF
  • show ip ospf database router - pełne dane o routerach i ich połączeniach

Każdemu protokołowi routingu CISCO przypisuje wartość AD (administrative distance). CISCO wybiera trasy biorąc pod uwagę wpierw trasy z najmniejszą AD, potem porównuje dopiero koszt. Zapis w tablicy routingu: [AD/koszt], np:

O 10.1.3.0/24 [110/65] via 10.3.4.3, 00:49:11, FastEthernet0/0 AD:110, koszt:65
D 10.0.2.0/24 [90/2297856] via 10.2.4.2, 00:09:38, Serial0/0 AD:90, koszt:2297856
C 10.4.5.0/24 is directly connected, FastEthernet0/1 AD:1

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_ospf/configuration/15-mt/iro-15-mt-book/iro-cfg.html

[Ekstra] Inne

Implementacje wielu protokołów routingu, w tym OSPFv2, dla systemu Linux:

sk1/cisco_ospf.txt · ostatnio zmienione: 2019/04/25 13:30 przez jkonczak