Association_mining Namespace

A Sandcastle Documented Class Library
Association_mining Namespace
Namespaces ► Association_mining

[Missing namespace summary documentation for N:Association_mining]

Declaration Syntax
C# Visual Basic Visual C++
namespace Association_mining
Namespace Association_mining
namespace Association_mining
Types
All Types Classes Delegates
Icon | Type | Description
 | AboutBox | Information box class.
 | Apriori | A static class containing methods used to mine frequent sets from a database.
 | Chart | Class responsible for displaying single charts.
 | ChartUtil | Class responsible for providing chart drawing functions.
 | CreateChart | Class providing an interface for the chart creation process.
 | CreateMultiChart | Class providing an interface for the multichart creation process.
 | Database | Database class.
 | DataGrid | Class responsible for displaying databases.
 | frmMain..::DisplayRulesCallback | A delegate used to update rule display.
 | FileProcessor | Contains functions responsible for reading and saving data and rule files.
 | FPGrowth | Static class providing functions needed to perform association mining with the Frequent Pattern Growth algorithm.
 | FPNode | Class representing an node of an FPTree.
 | FPTree | The FPTree class.
 | FrequentSet | Class representing a frequent set. That is a set with a known support and universe count (size of the database)
 | frmMain | The main program form.
 | Header | A header structure allowing to quickly localize all th nodes with the same item.
 | frmMain..::IntThreadCallback | A delegate used invoke functions with one int parameter by a background thread.
 | Item | A class representing a single item. As an item we understand a unique pair of an attribute type and name.
 | MinSupp | Provides an interface to provide minimal measure values required later to generate rules.
 | MultiChart | The multi chart class.
 | Program | Class responsoible for starting and running the program.
 | RecordHolder | Class responsible for creating databases and holding there logical structure.
 | Rule | Rule class. Contains all the nesesary information about a rule like it's support, confidence, confirmation and others.
 | RuleComparer |
 | SetUtil | A static class providing basic functions that operate on sets. This includes rule generation, creation of subsets, parsing sets to strings etc.
 | SortableBindingList<(Of <T>)> | A sortable list that can be bound to a DataGrid, DataGridView, DataSet or DataTable component
 | SupportComparer | Allows to compare support values in ore=der to sort them in descending order.
 | frmMain..::ThreadCallback | A delegate used invoke functions without parameters by a background thread.


AboutBox Class

AboutBox Class
Namespaces ► Association_mining ► AboutBox
Information box class.
Declaration Syntax
C# Visual Basic Visual C++
internal class AboutBox : Form
Friend Class AboutBox _
    Inherits Form
internal ref class AboutBox : public Form
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AboutBoxAboutBoxNew()() | Default constructor for the About Box.
 | AssemblyCompany | Read only property showing the Company Name.
 | AssemblyCopyright | Read only property.
 | AssemblyDescription | Read only property showing the Description.
 | AssemblyProduct | Read only property.
 | AssemblyTitle | Read only property showing the Title used for the Assembly.
 | AssemblyVersion | Read only property showing the Version of the Assembly.
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | AboutBox

Assembly: Association mining (Module: Association mining) Version: 1.0.0.0


AboutBox Constructor

AboutBox Constructor
Namespaces ► Association_mining ► AboutBox ► AboutBoxAboutBoxNew()()
Default constructor for the About Box.
Declaration Syntax
C# Visual Basic Visual C++
public AboutBox()
Public Sub New
public:
AboutBox ()


AssemblyCompany Property

AssemblyCompany Property
Namespaces ► Association_mining ► AboutBox ► AssemblyCompany
Read only property showing the Company Name.
Declaration Syntax
C# Visual Basic Visual C++
public string AssemblyCompany{ get;}
Public ReadOnly Property AssemblyCompany As String
public:
property String^ AssemblyCompany {
    String^ get ();
}
Return Value
Company Name


AssemblyCopyright Property

AssemblyCopyright Property
Namespaces ► Association_mining ► AboutBox ► AssemblyCopyright
Read only property.
Declaration Syntax
C# Visual Basic Visual C++
public string AssemblyCopyright{ get;}
Public ReadOnly Property AssemblyCopyright As String
public:
property String^ AssemblyCopyright {
    String^ get ();
}


AssemblyDescription Property

AssemblyDescription Property
Namespaces ► Association_mining ► AboutBox ► AssemblyDescription
Read only property showing the Description.
Declaration Syntax
C# Visual Basic Visual C++
public string AssemblyDescription{ get;}
Public ReadOnly Property AssemblyDescription As String
public:
property String^ AssemblyDescription {
    String^ get ();
}
Return Value
Product/Project description


AssemblyProduct Property

AssemblyProduct Property
Namespaces ► Association_mining ► AboutBox ► AssemblyProduct
Read only property.
Declaration Syntax
C# Visual Basic Visual C++
public string AssemblyProduct{ get;}
Public ReadOnly Property AssemblyProduct As String
public:
property String^ AssemblyProduct {
    String^ get ();
}


AssemblyTitle Property

AssemblyTitle Property
Namespaces ► Association_mining ► AboutBox ► AssemblyTitle
Read only property showing the Title used for the Assembly.
Declaration Syntax
C# Visual Basic Visual C++
public string AssemblyTitle{ get;}
Public ReadOnly Property AssemblyTitle As String
public:
property String^ AssemblyTitle {
    String^ get ();
}
Return Value
Product/Project title


AssemblyVersion Property

AssemblyVersion Property
Namespaces ► Association_mining ► AboutBox ► AssemblyVersion
Read only property showing the Version of the Assembly.
Declaration Syntax
C# Visual Basic Visual C++
public string AssemblyVersion{ get;}
Public ReadOnly Property AssemblyVersion As String
public:
property String^ AssemblyVersion {
    String^ get ();
}
Return Value
Product/Project version


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Association_mining ► AboutBox ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose (
    bool disposing
) override
Parameters
disposing (Boolean)


Apriori Class

Apriori Class
Namespaces ► Association_mining ► Apriori
A static class containing methods used to mine frequent sets from a database.
Declaration Syntax
C# Visual Basic Visual C++
public static class Apriori
Public NotInheritable Class Apriori
public ref class Apriori abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GenerateFrequentSets(Database, Double) | Generates a list of frequent sets form a database.
 | MiningAlgorithm(frmMain, Database, List<(Of <Set>)>, Double, Double, Double, Double, Double) | Implementation of the Apriori algorithm.
Inheritance Hierarchy
Object
Apriori


GenerateFrequentSets Method (data, minsup)

GenerateFrequentSets Method (data, minsup)
Namespaces ► Association_mining ► Apriori ► GenerateFrequentSets(Database, Double)
Generates a list of frequent sets form a database.
Declaration Syntax
C# Visual Basic Visual C++
public static List<FrequentSet> GenerateFrequentSets(
    Database data,
    double minsup
)
Public Shared Function GenerateFrequentSets ( _
    data As Database, _
    minsup As Double _
) As List(Of FrequentSet)
public:
static List<FrequentSet^>^ GenerateFrequentSets (
    Database^ data,
    double minsup
)
Parameters
data (Database)
Database to generate frequent sets from
minsup (Double)
Desired minimal support
Return Value
A list of frequent sets fulfilling the minimal support requirement.


MiningAlgorithm Method (MainForm, data, ConclusionList, minsup, minconf, mins, minf, maxanti)

MiningAlgorithm Method (MainForm, data, ConclusionList, minsup, minconf, mins, minf, maxanti)
Namespaces ► Association_mining ► Apriori ► MiningAlgorithm(frmMain, Database, List<(Of <Set>)>, Double, Double, Double, Double, Double)
Implementation of the Apriori algorithm.
Declaration Syntax
C# Visual Basic Visual C++
public static SortableBindingList<Rule> MiningAlgorithm(
    frmMain MainForm,
    Database data,
    List<Set> ConclusionList,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxanti
)
Public Shared Function MiningAlgorithm ( _
    MainForm As frmMain, _
    data As Database, _
    ConclusionList As List(Of Set), _
    minsup As Double, _
    minconf As Double, _
    mins As Double, _
    minf As Double, _
    maxanti As Double _
) As SortableBindingList(Of Rule)
public:
static SortableBindingList<Rule^>^ MiningAlgorithm (
    frmMain^ MainForm,
    Database^ data,
    List<Set^>^ ConclusionList,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxanti
)
Parameters
MainForm (frmMain)
The main program form
data (Database)
Database to generate rules from
ConclusionList (List <(Of <Set>)>)
A list of conclusions
minsup (Double)
Minimal support
minconf (Double)
Minimal confidence
mins (Double)
Minimal confirmation-s
minf (Double)
Minimal confirmation-f
maxanti (Double)
Maximal anti-support
Return Value
A list of rules matching the minimal support and other requirements


Chart Class

Chart Class
Namespaces ► Association_mining ► Chart
Class responsible for displaying single charts.
Declaration Syntax
C# Visual Basic Visual C++
public class Chart : Form
Public Class Chart _
    Inherits Form
public ref class Chart : public Form
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon Member Description
ChartChartNew()()
Default constructor.

ChartChartNew(List<(Of <Rule>)>, Int32, Double, Double, Double, Double, Double)
Creates a new chart object of a given type based on the given rules and minimal support

AddToGrid(Rule)
Adds a rule to the datagrid.

AdjustParameters()()
Adjusts the window size to fit the drawing requirements.

BRCount
Number of "blue" (F>=0) rules.

button1_Click(Object, EventArgs)
Saves the chart in *.bmp format.

CGraphics
Graphics object representing the plane the chart is drawn on.

Change(Object, EventArgs)
Forces the chart to repaint itself.

CType
A variable specifying the chart type.
  1. 1 signifies Confidence chart
  2. 2 signifies Confirmation-S chart
  3. 3 signifies Confirmation-F chart
  4. 4 signifies Anti-support chart

Dispose(Boolean)
Clean up any resources being used.
(Overrides Form.Dispose(Boolean).)
LastPoint
Last point the mouse cursor visited in selection mode. Used to draw the lasso.

minSup
Minimal support for displayed rules.

minSupAbs
Absolute minimal support defined by the minimal support used to generate rules.

minYValue
Minimal (or maximal) possible value on the Y axis.

minYValueAbs
Minimal (or maximal) possible value on the Y axis. defined by the minimal/maximal value used to generate rules.

Mouse_Down(Object, MouseEventArgs)
Starts drawing the lasso.

Mouse_Move(Object, MouseEventArgs)
Draws the lasso.

Mouse_Up(Object, MouseEventArgs)
Closes the lasso.

OrigPoint
First point in drawing the lasso in selection mode. Defined by the mouse position during the MouseDown event.

PaintChart(Object, PaintEventArgs)
Paints the chart.

Painter
Painter object responsible for providing basic chart drawing functions.

RRCount
Number of "red" (F < 0) rules.

Rules
A list of rules with the same conclusion to be drawn.

Selection
A GraphicsPath object responsible for drawing the lasso.

selectMode
Variable showing if the user is selecting rules. Used to tell the paint function to draw the lasso.

tboxSup
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | Chart


Chart Constructor

Chart Constructor
Namespaces ► Association_mining ► Chart ► ChartChartNew()()
Members
Icon | Member | Description
 | ChartChartNew()() | Default constructor.
 | ChartChartNew(List<(Of <Rule>)>, Int32, Double, Double, Double, Double, Double) | Creates a new chart object of a given type based on the given rules and minimal support


Chart Constructor

Chart Constructor
Namespaces ► Association_mining ► Chart ► ChartChartNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public Chart()
Public Sub New
public:
Chart ()


Chart Constructor (ruleList, type, minsup, minconf, mins, minf, maxa)

Chart Constructor (ruleList, type, minsup, minconf, mins, minf, maxa)
Namespaces ► Association_mining ► Chart ► ChartChartNew(List<(Of <Rule>)>, Int32, Double, Double, Double, Double, Double)
Creates a new chart object of a given type based on the given rules and minimal support
Declaration Syntax
C# Visual Basic Visual C++
public Chart(
    List<Rule> ruleList,
    int type,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxa
)
Public Sub New ( _
    ruleList As List(Of Rule), _
    type As Integer, _
    minsup As Double, _
    minconf As Double, _
    mins As Double, _
    minf As Double, _
    maxa As Double _
)
public:
Chart (
    List<Rule^>^ ruleList,
    int type,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxa
)
Parameters
ruleList (List <(Of < Rule >)>)
List of rules with the same conclusion
type (Int32)
Defines the type of chart to draw
  1. 1 signifies Confidence chart
  2. 2 signifies Confirmation-S chart
  3. 3 signifies Confirmation-F chart
  4. 4 signifies Anti-support chart
minsup (Double)
Absolute minimal support
minconf (Double)
Minimal confidence
mins (Double)
Minimal confirmation-s
minf (Double)
Minimal confirmation-f
maxa (Double)
Maximal anti-support


AddToGrid Method (r)

AddToGrid Method (r)
Namespaces ► Association_mining ► Chart ► AddToGrid(Rule)
Adds a rule to the datagrid.
Declaration Syntax
C# Visual Basic Visual C++
protected void AddToGrid(
    Rule r
)
Protected Sub AddToGrid ( _
    r As Rule _
)
protected:
void AddToGrid (
    Rule^ r
)
Parameters
r (Rule)
Rule to be added to the datagrid


AdjustParameters Method

AdjustParameters Method
Namespaces ► Association_mining ► Chart ► AdjustParameters()()
Adjusts the window size to fit the drawing requirements.
Declaration Syntax
C# Visual Basic Visual C++
protected void AdjustParameters()
Protected Sub AdjustParameters
protected:
void AdjustParameters ()


BRCount Field

BRCount Field
Namespaces ► Association_mining ► Chart ► BRCount
Number of "blue" (F>=0) rules.
Declaration Syntax
C# Visual Basic Visual C++
protected int BRCount
Protected BRCount As Integer
protected:
int BRCount


button1_Click Method (sender, e)

button1_Click Method (sender, e)
Namespaces ► Association_mining ► Chart ► button1_Click(Object, EventArgs)
Saves the chart in *.bmp format.
Declaration Syntax
C# Visual Basic Visual C++
protected void button1_Click(
    Object sender,
    EventArgs e
)
Protected Sub button1_Click ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void button1_Click (
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


CGraphics Field

CGraphics Field
Namespaces ► Association_mining ► Chart ► CGraphics
Graphics object representing the plane the chart is drawn on.
Declaration Syntax
C# Visual Basic Visual C++
protected Graphics CGraphics
Protected CGraphics As Graphics
protected:
Graphics^ CGraphics


Change Method (sender, e)

Change Method (sender, e)
Namespaces ► Association_mining ► Chart ► Change(Object, EventArgs)
Forces the chart to repaint itself.
Declaration Syntax
C# Visual Basic Visual C++
protected void Change(
    Object sender,
    EventArgs e
)
Protected Sub Change ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void Change (
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


CType Field

CType Field
Namespaces ► Association_mining ► Chart ► CType
A variable specifying the chart type.
  1. 1 signifies Confidence chart
  2. 2 signifies Confirmation-S chart
  3. 3 signifies Confirmation-F chart
  4. 4 signifies Anti-support chart
Declaration Syntax
C# Visual Basic Visual C++
protected int CType
Protected CType As Integer
protected:
int CType


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Association_mining ► Chart ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose (
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


LastPoint Field

LastPoint Field
Namespaces ► Association_mining ► Chart ► LastPoint
Last point the mouse cursor visited in selection mode. Used to draw the lasso.
Declaration Syntax
C# Visual Basic Visual C++
protected Point LastPoint
Protected LastPoint As Point
protected:
Point LastPoint


minSup Field

minSup Field
Namespaces ► Association_mining ► Chart ► minSup
Minimal support for displayed rules.
Declaration Syntax
C# Visual Basic Visual C++
protected double minSup
Protected minSup As Double
protected:
double minSup


minSupAbs Field

minSupAbs Field
Namespaces ► Association_mining ► Chart ► minSupAbs
Absolute minimal support defined by the minimal support used to generate rules.
Declaration Syntax
C# Visual Basic Visual C++
protected double minSupAbs
Protected minSupAbs As Double
protected:
double minSupAbs


minYValue Field

minYValue Field
Namespaces ► Association_mining ► Chart ► minYValue
Minimal (or maximal) possible value on the Y axis.
Declaration Syntax
C# Visual Basic Visual C++
protected double minYValue
Protected minYValue As Double
protected:
double minYValue


minYValueAbs Field

minYValueAbs Field
Namespaces ► Association_mining ► Chart ► minYValueAbs
Minimal (or maximal) possible value on the Y axis. defined by the minimal/maximal value used to generate rules.
Declaration Syntax
C# Visual Basic Visual C++
protected double minYValueAbs
Protected minYValueAbs As Double
protected:
double minYValueAbs


Mouse_Down Method (sender, e)

Mouse_Down Method (sender, e)
Namespaces ► Association_mining ► Chart ► Mouse_Down(Object, MouseEventArgs)
Starts drawing the lasso.
Declaration Syntax
C# Visual Basic Visual C++
protected void Mouse_Down(
    Object sender,
    MouseEventArgs e
)
Protected Sub Mouse_Down ( _
    sender As Object, _
    e As MouseEventArgs _
)
protected:
void Mouse_Down (
    Object^ sender,
    MouseEventArgs^ e
)
Parameters
sender (Object)
e (MouseEventArgs)


Mouse_Move Method (sender, e)

Mouse_Move Method (sender, e)
Namespaces ► Association_mining ► Chart ► Mouse_Move(Object, MouseEventArgs)
Draws the lasso.
Declaration Syntax
C# Visual Basic Visual C++
protected void Mouse_Move(
    Object sender,
    MouseEventArgs e
)
Protected Sub Mouse_Move ( _
    sender As Object, _
    e As MouseEventArgs _
)
protected:
void Mouse_Move (
    Object^ sender,
    MouseEventArgs^ e
)
Parameters
sender (Object)
e (MouseEventArgs)


Mouse_Up Method (sender, e)

Mouse_Up Method (sender, e)
Namespaces ► Association_mining ► Chart ► Mouse_Up(Object, MouseEventArgs)
Closes the lasso.
Declaration Syntax
C# Visual Basic Visual C++
protected void Mouse_Up(
    Object sender,
    MouseEventArgs e
)
Protected Sub Mouse_Up ( _
    sender As Object, _
    e As MouseEventArgs _
)
protected:
void Mouse_Up (
    Object^ sender,
    MouseEventArgs^ e
)
Parameters
sender (Object)
e (MouseEventArgs)


OrigPoint Field

OrigPoint Field
Namespaces ► Association_mining ► Chart ► OrigPoint
First point in drawing the lasso in selection mode. Defined by the mouse position during the MouseDown event.
Declaration Syntax
C# Visual Basic Visual C++
protected Point OrigPoint
Protected OrigPoint As Point
protected:
Point OrigPoint


PaintChart Method (sender, e)

PaintChart Method (sender, e)
Namespaces ► Association_mining ► Chart ► PaintChart(Object, PaintEventArgs)
Paints the chart.
Declaration Syntax
C# Visual Basic Visual C++
protected void PaintChart(
    Object sender,
    PaintEventArgs e
)
Protected Sub PaintChart ( _
    sender As Object, _
    e As PaintEventArgs _
)
protected:
void PaintChart (
    Object^ sender,
    PaintEventArgs^ e
)
Parameters
sender (Object)
e (PaintEventArgs)


Painter Field

Painter Field
Namespaces ► Association_mining ► Chart ► Painter
Painter object responsible for providing basic chart drawing functions.
Declaration Syntax
C# Visual Basic Visual C++
protected ChartUtil Painter
Protected Painter As ChartUtil
protected:
ChartUtil^ Painter


RRCount Field

RRCount Field
Namespaces ► Association_mining ► Chart ► RRCount
Number of "red" (F < 0) rules.
Declaration Syntax
C# Visual Basic Visual C++
protected int RRCount
Protected RRCount As Integer
protected:
int RRCount


Rules Field

Rules Field
Namespaces ► Association_mining ► Chart ► Rules
A list of rules with the same conclusion to be drawn.
Declaration Syntax
C# Visual Basic Visual C++
protected List<Rule> Rules
Protected Rules As List(Of Rule)
protected:
List<Rule^>^ Rules


Selection Field

Selection Field
Namespaces ► Association_mining ► Chart ► Selection
A GraphicsPath object responsible for drawing the lasso.
Declaration Syntax
C# Visual Basic Visual C++
protected GraphicsPath Selection
Protected Selection As GraphicsPath
protected:
GraphicsPath^ Selection


selectMode Field

selectMode Field
Namespaces ► Association_mining ► Chart ► selectMode
Variable showing if the user is selecting rules. Used to tell the paint function to draw the lasso.
Declaration Syntax
C# Visual Basic Visual C++
protected bool selectMode
Protected selectMode As Boolean
protected:
bool selectMode


tboxSup Field

tboxSup Field
Namespaces ► Association_mining ► Chart ► tboxSup

[Missing <summary> documentation for F:Association_mining.Chart.tboxSup]

Declaration Syntax
C# Visual Basic Visual C++
internal TextBox tboxSup
Friend tboxSup As TextBox
internal:
TextBox^ tboxSup


ChartUtil Class

ChartUtil Class
Namespaces ► Association_mining ► ChartUtil
Class responsible for providing chart drawing functions.
Declaration Syntax
C# Visual Basic Visual C++
public class ChartUtil
Public Class ChartUtil
public ref class ChartUtil
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChartUtilChartUtilNew()() |
 | DrawBorder(Graphics, Int32, Int32, Int32, Rule) | Draws border.
 | DrawEmptyCircle(Graphics, Int32, Int32) | Draws a empty circle on Graphics g in the point x,y.
 | DrawEmptyTriangle(Graphics, Int32, Int32) | Draws a empty triangle on Graphics g in the point x,y.
 | DrawFullCircle(Graphics, Int32, Int32) | Draws a full (red) circle on Graphics g in the point x,y.
 | DrawFullCircle(Graphics, Int32, Int32, Single) | Draws a full (red) circle on Graphics g in the point x,y.
 | DrawFullTriangle(Graphics, Int32, Int32) | Draws a full (blue) triangle on Graphics g in the point x,y.
 | DrawFullTriangle(Graphics, Int32, Int32, Single) | Draws a full (blue) triangle on Graphics g in the point x,y.
 | DrawLasso(Graphics, GraphicsPath) | Draws a lasso.
 | DrawNet(Graphics, Int32, Int32, Int32, Rule, Single) | Draws chart grid depending on the chart type.
 | DrawParetoRule(Graphics, Int32, Int32, Int32, List<(Of <Rule>)>, Int32%, Int32%) | Draws pareto rules (only).
 | DrawParetoRuleVisible(Graphics, Int32, Int32, Int32, List<(Of <Rule>)>, Int32%, Int32%) | Draws pareto rules (and "invisible" rules as well.
 | DrawRule(Graphics, Int32, Int32, Int32, List<(Of <Rule>)>, Int32%, Int32%, Boolean) | Draws rules.
 | DrawRuleCount(Graphics, Int32, Int32, Int32, Int32, Single) | Draws the number of each type of rules.
 | DrawSelected(Graphics, Int32, Int32, Int32, List<(Of <Rule>)>, Int32%, Int32%, Boolean, GraphicsPath, Int32) | Draws only the selected rules.
 | maxAnti | Maximal anti-support.
 | minConf | Mnimal confidence.
 | minF | Mnimal confirmation-f.
 | minS | Mnimal confirmation-s
 | minSup | Mnimal support.
 | SetMinValues(Double, Double, Double, Double, Double) | Sets minimal values of all measures.
Inheritance Hierarchy
Object
ChartUtil


ChartUtil Constructor

ChartUtil Constructor
Namespaces ► Association_mining ► ChartUtil ► ChartUtilChartUtilNew()()
Initializes a new instance of the ChartUtil class.
Declaration Syntax
C# Visual Basic Visual C++
public ChartUtil()
Public Sub New
public:
ChartUtil ()


DrawBorder Method (g, CWidth, CHeight, type, r)

DrawBorder Method (g, CWidth, CHeight, type, r)
Namespaces ► Association_mining ► ChartUtil ► DrawBorder(Graphics, Int32, Int32, Int32, Rule)
Draws border.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawBorder(
    Graphics g,
    int CWidth,
    int CHeight,
    int type,
    Rule r
)
Public Sub DrawBorder ( _
    g As Graphics, _
    CWidth As Integer, _
    CHeight As Integer, _
    type As Integer, _
    r As Rule _
)
public:
void DrawBorder (
    Graphics^ g,
    int CWidth,
    int CHeight,
    int type,
    Rule^ r
)
Parameters
g (Graphics)
Graphics object to draw on
CWidth (Int32)
Chart width
CHeight (Int32)
Chart height
type (Int32)
Chart type
r (Rule)
Rule required to draw the border


DrawEmptyCircle Method (g, x, y)

DrawEmptyCircle Method (g, x, y)
Namespaces ► Association_mining ► ChartUtil ► DrawEmptyCircle(Graphics, Int32, Int32)
Draws a empty circle on Graphics g in the point x,y.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawEmptyCircle(
    Graphics g,
    int x,
    int y
)
Public Sub DrawEmptyCircle ( _
    g As Graphics, _
    x As Integer, _
    y As Integer _
)
public:
void DrawEmptyCircle (
    Graphics^ g,
    int x,
    int y
)
Parameters
g (Graphics)
Graphics object to draw on
x (Int32)
X coordinate of the point to draw
y (Int32)
Y coordinate of the point to draw


DrawEmptyTriangle Method (g, x, y)

DrawEmptyTriangle Method (g, x, y)
Namespaces ► Association_mining ► ChartUtil ► DrawEmptyTriangle(Graphics, Int32, Int32)
Draws a empty triangle on Graphics g in the point x,y.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawEmptyTriangle(
    Graphics g,
    int x,
    int y
)
Public Sub DrawEmptyTriangle ( _
    g As Graphics, _
    x As Integer, _
    y As Integer _
)
public:
void DrawEmptyTriangle (
    Graphics^ g,
    int x,
    int y
)
Parameters
g (Graphics)
Graphics object to draw on
x (Int32)
X coordinate of the point to draw
y (Int32)
Y coordinate of the point to draw


DrawFullCircle Method

DrawFullCircle Method
Namespaces ► Association_mining ► ChartUtil ► DrawFullCircle()()
Members
Icon | Member | Description
 | DrawFullCircle(Graphics, Int32, Int32) | Draws a full (red) circle on Graphics g in the point x,y.
 | DrawFullCircle(Graphics, Int32, Int32, Single) | Draws a full (red) circle on Graphics g in the point x,y.


DrawFullCircle Method (g, x, y)

DrawFullCircle Method (g, x, y)
Namespaces ► Association_mining ► ChartUtil ► DrawFullCircle(Graphics, Int32, Int32)
Draws a full (red) circle on Graphics g in the point x,y.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawFullCircle(
    Graphics g,
    int x,
    int y
)
Public Sub DrawFullCircle ( _
    g As Graphics, _
    x As Integer, _
    y As Integer _
)
public:
void DrawFullCircle (
    Graphics^ g,
    int x,
    int y
)
Parameters
g (Graphics)
Graphics object to draw on
x (Int32)
X coordinate of the point to draw
y (Int32)
Y coordinate of the point to draw


DrawFullCircle Method (g, x, y, size)

DrawFullCircle Method (g, x, y, size)
Namespaces ► Association_mining ► ChartUtil ► DrawFullCircle(Graphics, Int32, Int32, Single)
Draws a full (red) circle on Graphics g in the point x,y.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawFullCircle(
    Graphics g,
    int x,
    int y,
    float size
)
Public Sub DrawFullCircle ( _
    g As Graphics, _
    x As Integer, _
    y As Integer, _
    size As Single _
)
public:
void DrawFullCircle (
    Graphics^ g,
    int x,
    int y,
    float size
)
Parameters
g (Graphics)
Graphics object to draw on
x (Int32)
X coordinate of the point to draw
y (Int32)
Y coordinate of the point to draw
size (Single)
Size of the circle


DrawFullTriangle Method

DrawFullTriangle Method
Namespaces ► Association_mining ► ChartUtil ► DrawFullTriangle()()
Members
Icon | Member | Description
 | DrawFullTriangle(Graphics, Int32, Int32) | Draws a full (blue) triangle on Graphics g in the point x,y.
 | DrawFullTriangle(Graphics, Int32, Int32, Single) | Draws a full (blue) triangle on Graphics g in the point x,y.


DrawFullTriangle Method (g, x, y)

DrawFullTriangle Method (g, x, y)
Namespaces ► Association_mining ► ChartUtil ► DrawFullTriangle(Graphics, Int32, Int32)
Draws a full (blue) triangle on Graphics g in the point x,y.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawFullTriangle(
    Graphics g,
    int x,
    int y
)
Public Sub DrawFullTriangle ( _
    g As Graphics, _
    x As Integer, _
    y As Integer _
)
public:
void DrawFullTriangle (
    Graphics^ g,
    int x,
    int y
)
Parameters
g (Graphics)
Graphics object to draw on
x (Int32)
X coordinate of the point to draw
y (Int32)
Y coordinate of the point to draw


DrawFullTriangle Method (g, x, y, size)

DrawFullTriangle Method (g, x, y, size)
Namespaces ► Association_mining ► ChartUtil ► DrawFullTriangle(Graphics, Int32, Int32, Single)
Draws a full (blue) triangle on Graphics g in the point x,y.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawFullTriangle(
    Graphics g,
    int x,
    int y,
    float size
)
Public Sub DrawFullTriangle ( _
    g As Graphics, _
    x As Integer, _
    y As Integer, _
    size As Single _
)
public:
void DrawFullTriangle (
    Graphics^ g,
    int x,
    int y,
    float size
)
Parameters
g (Graphics)
Graphics object to draw on
x (Int32)
X coordinate of the point to draw
y (Int32)
Y coordinate of the point to draw
size (Single)
Size of the triangle


DrawLasso Method (g, selection)

DrawLasso Method (g, selection)
Namespaces ► Association_mining ► ChartUtil ► DrawLasso(Graphics, GraphicsPath)
Draws a lasso.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawLasso(
    Graphics g,
    GraphicsPath selection
)
Public Sub DrawLasso ( _
    g As Graphics, _
    selection As GraphicsPath _
)
public:
void DrawLasso (
    Graphics^ g,
    GraphicsPath^ selection
)
Parameters
g (Graphics)
Graphics object to draw on
selection (GraphicsPath)
Selection defining the lasso


DrawNet Method (g, CWidth, CHeight, type, r, fontSize)

DrawNet Method (g, CWidth, CHeight, type, r, fontSize)
Namespaces ► Association_mining ► ChartUtil ► DrawNet(Graphics, Int32, Int32, Int32, Rule, Single)
Draws chart grid depending on the chart type.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawNet(
    Graphics g,
    int CWidth,
    int CHeight,
    int type,
    Rule r,
    float fontSize
)
Public Sub DrawNet ( _
    g As Graphics, _
    CWidth As Integer, _
    CHeight As Integer, _
    type As Integer, _
    r As Rule, _
    fontSize As Single _
)
public:
void DrawNet (
    Graphics^ g,
    int CWidth,
    int CHeight,
    int type,
    Rule^ r,
    float fontSize
)
Parameters
g (Graphics)
Graphics object to draw on
CWidth (Int32)
Chart width
CHeight (Int32)
Chart height
type (Int32)
Chart type
r (Rule)
Rule required to define confirmation-f borders
fontSize (Single)
Font size


DrawParetoRule Method (g, CWidth, CHeight, type, ruleList, rrCount, brCount)

DrawParetoRule Method (g, CWidth, CHeight, type, ruleList, rrCount, brCount)
Namespaces ► Association_mining ► ChartUtil ► DrawParetoRule(Graphics, Int32, Int32, Int32, List<(Of <Rule>)>, Int32%, Int32%)
Draws pareto rules (only).
Declaration Syntax
C# Visual Basic Visual C++
public void DrawParetoRule(
    Graphics g,
    int CWidth,
    int CHeight,
    int type,
    List<Rule> ruleList,
    ref int rrCount,
    ref int brCount
)
Public Sub DrawParetoRule ( _
    g As Graphics, _
    CWidth As Integer, _
    CHeight As Integer, _
    type As Integer, _
    ruleList As List(Of Rule), _
    ByRef rrCount As Integer, _
    ByRef brCount As Integer _
)
public:
void DrawParetoRule (
    Graphics^ g,
    int CWidth,
    int CHeight,
    int type,
    List<Rule^>^ ruleList,
    int% rrCount,
    int% brCount
)
Parameters
g (Graphics)
Graphics object to draw on
CWidth (Int32)
Chart width
CHeight (Int32)
Chart height
type (Int32)
Chart type
ruleList (List <(Of < Rule >)>)
Rule list
rrCount (Int32 %)
Number of "red" (F < 0) rules
brCount (Int32 %)
Number of "blue" (F >= 0) rules


DrawParetoRuleVisible Method (g, CWidth, CHeight, type, ruleList, rrCount, brCount)

DrawParetoRuleVisible Method (g, CWidth, CHeight, type, ruleList, rrCount, brCount)
Namespaces ► Association_mining ► ChartUtil ► DrawParetoRuleVisible(Graphics, Int32, Int32, Int32, List<(Of <Rule>)>, Int32%, Int32%)
Draws pareto rules (and "invisible" rules as well.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawParetoRuleVisible(
    Graphics g,
    int CWidth,
    int CHeight,
    int type,
    List<Rule> ruleList,
    ref int rrCount,
    ref int brCount
)
Public Sub DrawParetoRuleVisible ( _
    g As Graphics, _
    CWidth As Integer, _
    CHeight As Integer, _
    type As Integer, _
    ruleList As List(Of Rule), _
    ByRef rrCount As Integer, _
    ByRef brCount As Integer _
)
public:
void DrawParetoRuleVisible (
    Graphics^ g,
    int CWidth,
    int CHeight,
    int type,
    List<Rule^>^ ruleList,
    int% rrCount,
    int% brCount
)
Parameters
g (Graphics)
Graphics object to draw on
CWidth (Int32)
Chart width
CHeight (Int32)
Chart height
type (Int32)
Chart type
ruleList (List <(Of < Rule >)>)
Rule list
rrCount (Int32 %)
Number of "red" (F < 0) rules
brCount (Int32 %)
Number of "blue" (F >= 0) rules


DrawRule Method (g, CWidth, CHeight, type, ruleList, rrCount, brCount, invisible)

DrawRule Method (g, CWidth, CHeight, type, ruleList, rrCount, brCount, invisible)
Namespaces ► Association_mining ► ChartUtil ► DrawRule(Graphics, Int32, Int32, Int32, List<(Of <Rule>)>, Int32%, Int32%, Boolean)
Draws rules.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawRule(
    Graphics g,
    int CWidth,
    int CHeight,
    int type,
    List<Rule> ruleList,
    ref int rrCount,
    ref int brCount,
    bool invisible
)
Public Sub DrawRule ( _
    g As Graphics, _
    CWidth As Integer, _
    CHeight As Integer, _
    type As Integer, _
    ruleList As List(Of Rule), _
    ByRef rrCount As Integer, _
    ByRef brCount As Integer, _
    invisible As Boolean _
)
public:
void DrawRule (
    Graphics^ g,
    int CWidth,
    int CHeight,
    int type,
    List<Rule^>^ ruleList,
    int% rrCount,
    int% brCount,
    bool invisible
)
Parameters
g (Graphics)
Graphics object to draw on
CWidth (Int32)
Chart width
CHeight (Int32)
Chart height
type (Int32)
Chart type
ruleList (List <(Of < Rule >)>)
Rule list
rrCount (Int32 %)
Number of "red" (F < 0) rules
brCount (Int32 %)
Number of "blue" (F >= 0) rules
invisible (Boolean)
Tells whether "invisible" rules should be drawn


DrawRuleCount Method (g, CWidth, CHeight, rrCount, brCount, fontSize)

DrawRuleCount Method (g, CWidth, CHeight, rrCount, brCount, fontSize)
Namespaces ► Association_mining ► ChartUtil ► DrawRuleCount(Graphics, Int32, Int32, Int32, Int32, Single)
Draws the number of each type of rules.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawRuleCount(
    Graphics g,
    int CWidth,
    int CHeight,
    int rrCount,
    int brCount,
    float fontSize
)
Public Sub DrawRuleCount ( _
    g As Graphics, _
    CWidth As Integer, _
    CHeight As Integer, _
    rrCount As Integer, _
    brCount As Integer, _
    fontSize As Single _
)
public:
void DrawRuleCount (
    Graphics^ g,
    int CWidth,
    int CHeight,
    int rrCount,
    int brCount,
    float fontSize
)
Parameters
g (Graphics)
Graphics object to draw on
CWidth (Int32)
Chart width
CHeight (Int32)
Chart height
rrCount (Int32)
Number of "red" (F < 0) rules
brCount (Int32)
Number of "blue" (F >= 0) rules
fontSize (Single)
Font size


DrawSelected Method (g, CWidth, CHeight, type, ruleList, rrCount, brCount, invisible, selection, selectMode)

DrawSelected Method (g, CWidth, CHeight, type, ruleList, rrCount, brCount, invisible, selection, selectMode)
Namespaces ► Association_mining ► ChartUtil ► DrawSelected(Graphics, Int32, Int32, Int32, List<(Of <Rule>)>, Int32%, Int32%, Boolean, GraphicsPath, Int32)
Draws only the selected rules.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawSelected(
    Graphics g,
    int CWidth,
    int CHeight,
    int type,
    List<Rule> ruleList,
    ref int rrCount,
    ref int brCount,
    bool invisible,
    GraphicsPath selection,
    int selectMode
)
Public Sub DrawSelected ( _
    g As Graphics, _
    CWidth As Integer, _
    CHeight As Integer, _
    type As Integer, _
    ruleList As List(Of Rule), _
    ByRef rrCount As Integer, _
    ByRef brCount As Integer, _
    invisible As Boolean, _
    selection As GraphicsPath, _
    selectMode As Integer _
)
public:
void DrawSelected (
    Graphics^ g,
    int CWidth,
    int CHeight,
    int type,
    List<Rule^>^ ruleList,
    int% rrCount,
    int% brCount,
    bool invisible,
    GraphicsPath^ selection,
    int selectMode
)
Parameters
g (Graphics)
Graphics object to draw on
CWidth (Int32)
Chart width
CHeight (Int32)
Chart height
type (Int32)
Chart type
ruleList (List <(Of < Rule >)>)
Rule list
rrCount (Int32 %)
Number of "red" (F < 0) rules
brCount (Int32 %)
Number of "blue" (F >= 0) rules
invisible (Boolean)
Tells whether "invisible" rules should be drawn
selection (GraphicsPath)
Lasso
selectMode (Int32)
Defines which chart (if it's a multichart) has the selectin lasso on it


maxAnti Field

maxAnti Field
Namespaces ► Association_mining ► ChartUtil ► maxAnti
Maximal anti-support.
Declaration Syntax
C# Visual Basic Visual C++
protected double maxAnti
Protected maxAnti As Double
protected:
double maxAnti


minConf Field

minConf Field
Namespaces ► Association_mining ► ChartUtil ► minConf
Mnimal confidence.
Declaration Syntax
C# Visual Basic Visual C++
protected double minConf
Protected minConf As Double
protected:
double minConf


minF Field

minF Field
Namespaces ► Association_mining ► ChartUtil ► minF
Mnimal confirmation-f.
Declaration Syntax
C# Visual Basic Visual C++
protected double minF
Protected minF As Double
protected:
double minF


minS Field

minS Field
Namespaces ► Association_mining ► ChartUtil ► minS
Mnimal confirmation-s
Declaration Syntax
C# Visual Basic Visual C++
protected double minS
Protected minS As Double
protected:
double minS


minSup Field

minSup Field
Namespaces ► Association_mining ► ChartUtil ► minSup
Mnimal support.
Declaration Syntax
C# Visual Basic Visual C++
protected double minSup
Protected minSup As Double
protected:
double minSup


SetMinValues Method (mSup, mConf, mS, mF, mA)

SetMinValues Method (mSup, mConf, mS, mF, mA)
Namespaces ► Association_mining ► ChartUtil ► SetMinValues(Double, Double, Double, Double, Double)
Sets minimal values of all measures.
Declaration Syntax
C# Visual Basic Visual C++
public void SetMinValues(
    double mSup,
    double mConf,
    double mS,
    double mF,
    double mA
)
Public Sub SetMinValues ( _
    mSup As Double, _
    mConf As Double, _
    mS As Double, _
    mF As Double, _
    mA As Double _
)
public:
void SetMinValues (
    double mSup,
    double mConf,
    double mS,
    double mF,
    double mA
)
Parameters
mSup (Double)
Minimal support
mConf (Double)
Mnimal confidence
mS (Double)
Minimal confirmation-s
mF (Double)
Minimal confirmation-f
mA (Double)
Maximal anti-support


CreateChart Class

CreateChart Class
Namespaces ► Association_mining ► CreateChart
Class providing an interface for the chart creation process.
Declaration Syntax
C# Visual Basic Visual C++
public class CreateChart : Form
Public Class CreateChart _
    Inherits Form
public ref class CreateChart : public Form
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateChartCreateChartNew(List<(Of <List<(Of <Rule>)>>)>, List<(Of <Set>)>, Double, Double, Double, Double, Double) | Constructor. Rule structureList of conclusionsMinimal supportMinimal confidenceMinimal confirmation-sMinimal confirmation-fMaximal anti-support
 | Cancel_Click(Object, EventArgs) | Destroys the form.
 | cboxAll_CheckedChanged(Object, EventArgs) | Selects or deselects all checkboxes at once.
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | FilteredList | A list of rules with the same conclusion.
 | MaxAnti | Minimal support used to generate the rules in the structure.
 | MinConf | Minimal support used to generate the rules in the structure.
 | MinF | Minimal support used to generate the rules in the structure.
 | MinS | Minimal support used to generate the rules in the structure.
 | MinSup | Minimal support used to generate the rules in the structure.
 | OK_Click(Object, EventArgs) | Creates the specified chart.
 | Rules | Rule structure.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | CreateChart


CreateChart Constructor (ruleList, Conclusions, minsup, minconf, mins, minf, maxa)

CreateChart Constructor (ruleList, Conclusions, minsup, minconf, mins, minf, maxa)
Namespaces ► Association_mining ► CreateChart ► CreateChartCreateChartNew(List<(Of <List<(Of <Rule>)>>)>, List<(Of <Set>)>, Double, Double, Double, Double, Double)
Constructor. Rule structureList of conclusionsMinimal supportMinimal confidenceMinimal confirmation-sMinimal confirmation-fMaximal anti-support
Declaration Syntax
C# Visual Basic Visual C++
public CreateChart(
    List<List<Rule>> ruleList,
    List<Set> Conclusions,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxa
)
Public Sub New ( _
    ruleList As List(Of List(Of Rule)), _
    Conclusions As List(Of Set), _
    minsup As Double, _
    minconf As Double, _
    mins As Double, _
    minf As Double, _
    maxa As Double _
)
public:
CreateChart (
    List<List<Rule^>^>^ ruleList,
    List<Set^>^ Conclusions,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxa
)
Parameters
ruleList (List <(Of < List <(Of < Rule >)>>)>)
Conclusions (List <(Of <Set>)>)
minsup (Double)
minconf (Double)
mins (Double)
minf (Double)
maxa (Double)


Cancel_Click Method (sender, e)

Cancel_Click Method (sender, e)
Namespaces ► Association_mining ► CreateChart ► Cancel_Click(Object, EventArgs)
Destroys the form.
Declaration Syntax
C# Visual Basic Visual C++
protected void Cancel_Click(
    Object sender,
    EventArgs e
)
Protected Sub Cancel_Click ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void Cancel_Click (
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


cboxAll_CheckedChanged Method (sender, e)

cboxAll_CheckedChanged Method (sender, e)
Namespaces ► Association_mining ► CreateChart ► cboxAll_CheckedChanged(Object, EventArgs)
Selects or deselects all checkboxes at once.
Declaration Syntax
C# Visual Basic Visual C++
protected void cboxAll_CheckedChanged(
    Object sender,
    EventArgs e
)
Protected Sub cboxAll_CheckedChanged ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void cboxAll_CheckedChanged (
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Association_mining ► CreateChart ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose (
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


FilteredList Field

FilteredList Field
Namespaces ► Association_mining ► CreateChart ► FilteredList
A list of rules with the same conclusion.
Declaration Syntax
C# Visual Basic Visual C++
protected List<Rule> FilteredList
Protected FilteredList As List(Of Rule)
protected:
List<Rule^>^ FilteredList


MaxAnti Field

MaxAnti Field
Namespaces ► Association_mining ► CreateChart ► MaxAnti
Minimal support used to generate the rules in the structure.
Declaration Syntax
C# Visual Basic Visual C++
protected double MaxAnti
Protected MaxAnti As Double
protected:
double MaxAnti


MinConf Field

MinConf Field
Namespaces ► Association_mining ► CreateChart ► MinConf
Minimal support used to generate the rules in the structure.
Declaration Syntax
C# Visual Basic Visual C++
protected double MinConf
Protected MinConf As Double
protected:
double MinConf


MinF Field

MinF Field
Namespaces ► Association_mining ► CreateChart ► MinF
Minimal support used to generate the rules in the structure.
Declaration Syntax
C# Visual Basic Visual C++
protected double MinF
Protected MinF As Double
protected:
double MinF


MinS Field

MinS Field
Namespaces ► Association_mining ► CreateChart ► MinS
Minimal support used to generate the rules in the structure.
Declaration Syntax
C# Visual Basic Visual C++
protected double MinS
Protected MinS As Double
protected:
double MinS


MinSup Field

MinSup Field
Namespaces ► Association_mining ► CreateChart ► MinSup
Minimal support used to generate the rules in the structure.
Declaration Syntax
C# Visual Basic Visual C++
protected double MinSup
Protected MinSup As Double
protected:
double MinSup


OK_Click Method (sender, e)

OK_Click Method (sender, e)
Namespaces ► Association_mining ► CreateChart ► OK_Click(Object, EventArgs)
Creates the specified chart.
Declaration Syntax
C# Visual Basic Visual C++
protected void OK_Click(
    Object sender,
    EventArgs e
)
Protected Sub OK_Click ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void OK_Click (
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


Rules Field

Rules Field
Namespaces ► Association_mining ► CreateChart ► Rules
Rule structure.
Declaration Syntax
C# Visual Basic Visual C++
protected List<List<Rule>> Rules
Protected Rules As List(Of List(Of Rule))
protected:
List<List<Rule^>^>^ Rules


CreateMultiChart Class

CreateMultiChart Class
Namespaces ► Association_mining ► CreateMultiChart
Class providing an interface for the multichart creation process.
Declaration Syntax
C# Visual Basic Visual C++
public class CreateMultiChart : Form
Public Class CreateMultiChart _
    Inherits Form
public ref class CreateMultiChart : public Form
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateMultiChartCreateMultiChartNew(List<(Of <List<(Of <Rule>)>>)>, List<(Of <Set>)>, Double, Double, Double, Double, Double) | Constructor
 | Cacel_Click(Object, EventArgs) | Destroys the form.
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | FilteredList | A list of rules with the same conclusion.
 | MaxAnti | Minimal support used to generate the rules in the structure.
 | MinConf | Minimal support used to generate the rules in the structure.
 | MinF | Minimal support used to generate the rules in the structure.
 | MinS | Minimal support used to generate the rules in the structure.
 | MinSup | Minimal support used to generate the rules in the structure.
 | OK_Click(Object, EventArgs) | Creates the specified chart.
 | Rules | Rule structure.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | CreateMultiChart


CreateMultiChart Constructor (ruleList, Conclusions, minsup, minconf, mins, minf, maxa)

CreateMultiChart Constructor (ruleList, Conclusions, minsup, minconf, mins, minf, maxa)
Namespaces ► Association_mining ► CreateMultiChart ► CreateMultiChartCreateMultiChartNew(List<(Of <List<(Of <Rule>)>>)>, List<(Of <Set>)>, Double, Double, Double, Double, Double)
Constructor
Declaration Syntax
C# Visual Basic Visual C++
public CreateMultiChart(
    List<List<Rule>> ruleList,
    List<Set> Conclusions,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxa
)
Public Sub New ( _
    ruleList As List(Of List(Of Rule)), _
    Conclusions As List(Of Set), _
    minsup As Double, _
    minconf As Double, _
    mins As Double, _
    minf As Double, _
    maxa As Double _
)
public:
CreateMultiChart (
    List<List<Rule^>^>^ ruleList,
    List<Set^>^ Conclusions,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxa
)
Parameters
ruleList (List <(Of < List <(Of < Rule >)>>)>)
Rule list
Conclusions (List <(Of <Set>)>)
LList of conclusions
minsup (Double)
Minimal support
minconf (Double)
Minimal confidence
mins (Double)
Minimal confirmation-s
minf (Double)
Minimal confirmation-f
maxa (Double)
Maximal anti-support


Cacel_Click Method (sender, e)

Cacel_Click Method (sender, e)
Namespaces ► Association_mining ► CreateMultiChart ► Cacel_Click(Object, EventArgs)
Destroys the form.
Declaration Syntax
C# Visual Basic Visual C++
protected void Cacel_Click(
    Object sender,
    EventArgs e
)
Protected Sub Cacel_Click ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void Cacel_Click (
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Association_mining ► CreateMultiChart ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose (
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


FilteredList Field

FilteredList Field
Namespaces ► Association_mining ► CreateMultiChart ► FilteredList
A list of rules with the same conclusion.
Declaration Syntax
C# Visual Basic Visual C++
protected List<Rule> FilteredList
Protected FilteredList As List(Of Rule)
protected:
List<Rule^>^ FilteredList


MaxAnti Field

MaxAnti Field
Namespaces ► Association_mining ► CreateMultiChart ► MaxAnti
Minimal support used to generate the rules in the structure.
Declaration Syntax
C# Visual Basic Visual C++
protected double MaxAnti
Protected MaxAnti As Double
protected:
double MaxAnti


MinConf Field

MinConf Field
Namespaces ► Association_mining ► CreateMultiChart ► MinConf
Minimal support used to generate the rules in the structure.
Declaration Syntax
C# Visual Basic Visual C++
protected double MinConf
Protected MinConf As Double
protected:
double MinConf


MinF Field

MinF Field
Namespaces ► Association_mining ► CreateMultiChart ► MinF
Minimal support used to generate the rules in the structure.
Declaration Syntax
C# Visual Basic Visual C++
protected double MinF
Protected MinF As Double
protected:
double MinF


MinS Field

MinS Field
Namespaces ► Association_mining ► CreateMultiChart ► MinS
Minimal support used to generate the rules in the structure.
Declaration Syntax
C# Visual Basic Visual C++
protected double MinS
Protected MinS As Double
protected:
double MinS


MinSup Field

MinSup Field
Namespaces ► Association_mining ► CreateMultiChart ► MinSup
Minimal support used to generate the rules in the structure.
Declaration Syntax
C# Visual Basic Visual C++
protected double MinSup
Protected MinSup As Double
protected:
double MinSup


OK_Click Method (sender, e)

OK_Click Method (sender, e)
Namespaces ► Association_mining ► CreateMultiChart ► OK_Click(Object, EventArgs)
Creates the specified chart.
Declaration Syntax
C# Visual Basic Visual C++
protected void OK_Click(
    Object sender,
    EventArgs e
)
Protected Sub OK_Click ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void OK_Click (
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


Rules Field

Rules Field
Namespaces ► Association_mining ► CreateMultiChart ► Rules
Rule structure.
Declaration Syntax
C# Visual Basic Visual C++
protected List<List<Rule>> Rules
Protected Rules As List(Of List(Of Rule))
protected:
List<List<Rule^>^>^ Rules


Database Class

Database Class
Namespaces ► Association_mining ► Database
Database class.
Declaration Syntax
C# Visual Basic Visual C++
public class Database
Public Class Database
public ref class Database
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseDatabaseNew()() | Default constructor.
 | DatabaseDatabaseNew(RecordHolder, String) | Constructor. Creates a new database on the base of the given template.
 | AddRecord(array<String>[](), Int32) | Adds a record to the database.
 | BinaryColumnCount | The number of all columns in the database. This number is equal to the number of distinct pairs Type-Name.
 | ColumnCount | Number of distinct types in the database.
 | Item[([Int32, Int32])] | Allows to access any cell of the database.
 | RowCount | Number of records in the database.
 | Template | A template holding the logical structure of the database and giving a possibility to translate column meanings.
 | Text | Database name.
 | Translator | A hash dictionary translating the concatenated attribute type and name into a database column number.
Inheritance Hierarchy
Object
Database


Database Constructor

Database Constructor
Namespaces ► Association_mining ► Database ► DatabaseDatabaseNew()()
Members
Icon | Member | Description
 | DatabaseDatabaseNew()() | Default constructor.
 | DatabaseDatabaseNew(RecordHolder, String) | Constructor. Creates a new database on the base of the given template.


Database Constructor

Database Constructor
Namespaces ► Association_mining ► Database ► DatabaseDatabaseNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public Database()
Public Sub New
public:
Database ()


Database Constructor (rHolder, name)

Database Constructor (rHolder, name)
Namespaces ► Association_mining ► Database ► DatabaseDatabaseNew(RecordHolder, String)
Constructor. Creates a new database on the base of the given template.
Declaration Syntax
C# Visual Basic Visual C++
public Database(
    RecordHolder rHolder,
    string name
)
Public Sub New ( _
    rHolder As RecordHolder, _
    name As String _
)
public:
Database (
    RecordHolder^ rHolder,
    String^ name
)
Parameters
rHolder (RecordHolder)
Database template
name (String)
Database name


AddRecord Method (record, rlength)

AddRecord Method (record, rlength)
Namespaces ► Association_mining ► Database ► AddRecord(array<String>[](), Int32)
Adds a record to the database.
Declaration Syntax
C# Visual Basic Visual C++
public void AddRecord(
    string[] record,
    int rlength
)
Public Sub AddRecord ( _
    record As String(), _
    rlength As Integer _
)
public:
void AddRecord (
    array<String^>^ record,
    int rlength
)
Parameters
record (array< String >[]())
Record
rlength (Int32)
Record length


BinaryColumnCount Property

BinaryColumnCount Property
Namespaces ► Association_mining ► Database ► BinaryColumnCount
The number of all columns in the database. This number is equal to the number of distinct pairs Type-Name.
Declaration Syntax
C# Visual Basic Visual C++
public int BinaryColumnCount{ get;}
Public ReadOnly Property BinaryColumnCount As Integer
public:
property int BinaryColumnCount {
    int get ();
}


ColumnCount Property

ColumnCount Property
Namespaces ► Association_mining ► Database ► ColumnCount
Number of distinct types in the database.
Declaration Syntax
C# Visual Basic Visual C++
public int ColumnCount{ get;}
Public ReadOnly Property ColumnCount As Integer
public:
property int ColumnCount {
    int get ();
}


Item Property (x, y)

Item Property (x, y)
Namespaces ► Association_mining ► Database ► Item[([Int32, Int32])]
Allows to access any cell of the database.
Declaration Syntax
C# Visual Basic Visual C++
public byte this[
    int x,
    int y
]{ get;}
Public ReadOnly Default Property Item ( _
    x As Integer, _
    y As Integer _
) As Byte
public:
property unsigned char default[int x, int y] {
    unsigned char get (int x, int y);
}
Parameters
x (Int32)
Database row
y (Int32)
Database column
Return Value
The value contained in the x,y database cell


RowCount Property

RowCount Property
Namespaces ► Association_mining ► Database ► RowCount
Number of records in the database.
Declaration Syntax
C# Visual Basic Visual C++
public int RowCount{ get;}
Public ReadOnly Property RowCount As Integer
public:
property int RowCount {
    int get ();
}


Template Field

Template Field
Namespaces ► Association_mining ► Database ► Template
A template holding the logical structure of the database and giving a possibility to translate column meanings.
Declaration Syntax
C# Visual Basic Visual C++
public RecordHolder Template
Public Template As RecordHolder
public:
RecordHolder^ Template


Text Property

Text Property
Namespaces ► Association_mining ► Database ► Text
Database name.
Declaration Syntax
C# Visual Basic Visual C++
public string Text{ get; set;}
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}


Translator Field

Translator Field
Namespaces ► Association_mining ► Database ► Translator
A hash dictionary translating the concatenated attribute type and name into a database column number.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, int> Translator
Public Translator As Dictionary(Of String, Integer)
public:
Dictionary<String^, int>^ Translator


DataGrid Class

DataGrid Class
Namespaces ► Association_mining ► DataGrid
Class responsible for displaying databases.
Declaration Syntax
C# Visual Basic Visual C++
public class DataGrid : Form
Public Class DataGrid _
    Inherits Form
public ref class DataGrid : public Form
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DataGridDataGridNew()() | Default constructor.
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | LoadData(Database) | Loads data from the database d to the datagrid.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | DataGrid


DataGrid Constructor

DataGrid Constructor
Namespaces ► Association_mining ► DataGrid ► DataGridDataGridNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public DataGrid()
Public Sub New
public:
DataGrid ()


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Association_mining ► DataGrid ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose (
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


LoadData Method (d)

LoadData Method (d)
Namespaces ► Association_mining ► DataGrid ► LoadData(Database)
Loads data from the database d to the datagrid.
Declaration Syntax
C# Visual Basic Visual C++
public void LoadData(
    Database d
)
Public Sub LoadData ( _
    d As Database _
)
public:
void LoadData (
    Database^ d
)
Parameters
d (Database)
Database to be displayed


frmMain.DisplayRulesCallback Delegate

frmMain..::DisplayRulesCallback Delegate
Namespaces ► Association_mining ► frmMain ► frmMain..::DisplayRulesCallback
A delegate used to update rule display.
Declaration Syntax
C# Visual Basic Visual C++
private delegate void DisplayRulesCallback(
    SortableBindingList<Rule> ruleList
)
Private Delegate Sub DisplayRulesCallback ( _
    ruleList As SortableBindingList(Of Rule) _
)
private delegate void DisplayRulesCallback (
    SortableBindingList<Rule^>^ ruleList
)
Parameters
ruleList (SortableBindingList <(Of < Rule >)>)
Rule list


FileProcessor Class

FileProcessor Class
Namespaces ► Association_mining ► FileProcessor
Contains functions responsible for reading and saving data and rule files.
Declaration Syntax
C# Visual Basic Visual C++
public static class FileProcessor
Public NotInheritable Class FileProcessor
public ref class FileProcessor abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExportToCSV(DataGridView, FileStream) | Exports rules to Excel format.
 | ExportToExcel(DataGridView, FileStream) | Exports rules to Excel format.
 | OpenARFFFile(FileStream) | Opens an ARFF file.
 | OpenDATAFile(FileStream) | Opens a DATA file.
 | OpenRuleFile(FileStream, List<(Of <Set>)>, SortableBindingList<(Of <Rule>)>, Double%, Double%, Double%, Double%, Double%) | Opens a rule file.
 | SaveRules(FileStream, List<(Of <List<(Of <Rule>)>>)>, Int32, Double, Double, Double, Double, Double) | Saves a rule file
Inheritance Hierarchy
Object
FileProcessor


ExportToCSV Method (source, file)

ExportToCSV Method (source, file)
Namespaces ► Association_mining ► FileProcessor ► ExportToCSV(DataGridView, FileStream)
Exports rules to Excel format.
Declaration Syntax
C# Visual Basic Visual C++
public static void ExportToCSV(
    DataGridView source,
    FileStream file
)
Public Shared Sub ExportToCSV ( _
    source As DataGridView, _
    file As FileStream _
)
public:
static void ExportToCSV (
    DataGridView^ source,
    FileStream^ file
)
Parameters
source (DataGridView)
DataGridView displaying the rules
file (FileStream)
File


ExportToExcel Method (source, file)

ExportToExcel Method (source, file)
Namespaces ► Association_mining ► FileProcessor ► ExportToExcel(DataGridView, FileStream)
Exports rules to Excel format.
Declaration Syntax
C# Visual Basic Visual C++
public static void ExportToExcel(
    DataGridView source,
    FileStream file
)
Public Shared Sub ExportToExcel ( _
    source As DataGridView, _
    file As FileStream _
)
public:
static void ExportToExcel (
    DataGridView^ source,
    FileStream^ file
)
Parameters
source (DataGridView)
DataGridView displaying the rules
file (FileStream)
File


OpenARFFFile Method (file)

OpenARFFFile Method (file)
Namespaces ► Association_mining ► FileProcessor ► OpenARFFFile(FileStream)
Opens an ARFF file.
Declaration Syntax
C# Visual Basic Visual C++
public static Database OpenARFFFile(
    FileStream file
)
Public Shared Function OpenARFFFile ( _
    file As FileStream _
) As Database
public:
static Database^ OpenARFFFile (
    FileStream^ file
)
Parameters
file (FileStream)
File
Return Value
A database filled with records read from the file. Records that are incomplete are not taken into account.


OpenDATAFile Method (file)

OpenDATAFile Method (file)
Namespaces ► Association_mining ► FileProcessor ► OpenDATAFile(FileStream)
Opens a DATA file.
Declaration Syntax
C# Visual Basic Visual C++
public static Database OpenDATAFile(
    FileStream file
)
Public Shared Function OpenDATAFile ( _
    file As FileStream _
) As Database
public:
static Database^ OpenDATAFile (
    FileStream^ file
)
Parameters
file (FileStream)
File
Return Value
A database filled with records read from the file. Records that are incomplete are not taken into account.


OpenRuleFile Method (file, Conclusions, rules, minsupp, minconf, mins, minf, maxa)

OpenRuleFile Method (file, Conclusions, rules, minsupp, minconf, mins, minf, maxa)
Namespaces ► Association_mining ► FileProcessor ► OpenRuleFile(FileStream, List<(Of <Set>)>, SortableBindingList<(Of <Rule>)>, Double%, Double%, Double%, Double%, Double%)
Opens a rule file.
Declaration Syntax
C# Visual Basic Visual C++
public static List<List<Rule>> OpenRuleFile(
    FileStream file,
    List<Set> Conclusions,
    SortableBindingList<Rule> rules,
    out double minsupp,
    out double minconf,
    out double mins,
    out double minf,
    out double maxa
)
Public Shared Function OpenRuleFile ( _
    file As FileStream, _
    Conclusions As List(Of Set), _
    rules As SortableBindingList(Of Rule), _
    <OutAttribute> ByRef minsupp As Double, _
    <OutAttribute> ByRef minconf As Double, _
    <OutAttribute> ByRef mins As Double, _
    <OutAttribute> ByRef minf As Double, _
    <OutAttribute> ByRef maxa As Double _
) As List(Of List(Of Rule))
public:
static List<List<Rule^>^>^ OpenRuleFile (
    FileStream^ file,
    List<Set^>^ Conclusions,
    SortableBindingList<Rule^>^ rules,
    [OutAttribute] double% minsupp,
    [OutAttribute] double% minconf,
    [OutAttribute] double% mins,
    [OutAttribute] double% minf,
    [OutAttribute] double% maxa
)
Parameters
file (FileStream)
File
Conclusions (List <(Of <Set>)>)
Conclusion list
rules (SortableBindingList <(Of < Rule >)>)
Rule structure
minsupp (Double %)
Minimal support that was used to generate the rules
minconf (Double %)
Minimal confidence
mins (Double %)
Minimal confirmation-s
minf (Double %)
Minimal confirmation-f
maxa (Double %)
Maximal anti-support
Return Value

[Missing <returns> documentation for M:Association_mining.FileProcessor.OpenRuleFile(System.IO.FileStream,System.Collections.Generic.List{Iesi.Collections.Set},Association_mining.SortableBindingList{Association_mining.Rule},System.Double@,System.Double@,System.Double@,System.Double@,System.Double@)]


SaveRules Method (file, ruleStructure, conclusionCount, minsupp, minconf, mins, minf, maxa)

SaveRules Method (file, ruleStructure, conclusionCount, minsupp, minconf, mins, minf, maxa)
Namespaces ► Association_mining ► FileProcessor ► SaveRules(FileStream, List<(Of <List<(Of <Rule>)>>)>, Int32, Double, Double, Double, Double, Double)
Saves a rule file
Declaration Syntax
C# Visual Basic Visual C++
public static void SaveRules(
    FileStream file,
    List<List<Rule>> ruleStructure,
    int conclusionCount,
    double minsupp,
    double minconf,
    double mins,
    double minf,
    double maxa
)
Public Shared Sub SaveRules ( _
    file As FileStream, _
    ruleStructure As List(Of List(Of Rule)), _
    conclusionCount As Integer, _
    minsupp As Double, _
    minconf As Double, _
    mins As Double, _
    minf As Double, _
    maxa As Double _
)
public:
static void SaveRules (
    FileStream^ file,
    List<List<Rule^>^>^ ruleStructure,
    int conclusionCount,
    double minsupp,
    double minconf,
    double mins,
    double minf,
    double maxa
)
Parameters
file (FileStream)
File
ruleStructure (List <(Of < List <(Of < Rule >)>>)>)
Rule structure
conclusionCount (Int32)
Number of distinct conclusions in the structure
minsupp (Double)
Minimal support used to generate the rules
minconf (Double)
Minimal confidence
mins (Double)
Minimal confirmation-s
minf (Double)
Minimal confirmation-f
maxa (Double)
Maximal anti-support


FPGrowth Class

FPGrowth Class
Namespaces ► Association_mining ► FPGrowth
Static class providing functions needed to perform association mining with the Frequent Pattern Growth algorithm.
Declaration Syntax
C# Visual Basic Visual C++
public static class FPGrowth
Public NotInheritable Class FPGrowth
public ref class FPGrowth abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GenerateFrequentSets(Database, Double) | Generates frequent sets using the FPGrowth algorithm.
 | Grow(FPTree, FrequentSet) | The recursive Grow algorithm.
 | MiningAlgorithm(frmMain, Database, List<(Of <Set>)>, Double, Double, Double, Double, Double) | Creates an FPTree based on a given database and performs the FPGrowth algorithm.
Inheritance Hierarchy
Object
FPGrowth


GenerateFrequentSets Method (data, minsup)

GenerateFrequentSets Method (data, minsup)
Namespaces ► Association_mining ► FPGrowth ► GenerateFrequentSets(Database, Double)
Generates frequent sets using the FPGrowth algorithm.
Declaration Syntax
C# Visual Basic Visual C++
public static List<FrequentSet> GenerateFrequentSets(
    Database data,
    double minsup
)
Public Shared Function GenerateFrequentSets ( _
    data As Database, _
    minsup As Double _
) As List(Of FrequentSet)
public:
static List<FrequentSet^>^ GenerateFrequentSets (
    Database^ data,
    double minsup
)
Parameters
data (Database)
Database
minsup (Double)
Minimal support
Return Value
Frequent sets with support greater or equal to the given minimal support


Grow Method (tree, alpha)

Grow Method (tree, alpha)
Namespaces ► Association_mining ► FPGrowth ► Grow(FPTree, FrequentSet)
The recursive Grow algorithm.
Declaration Syntax
C# Visual Basic Visual C++
public static void Grow(
    FPTree tree,
    FrequentSet alpha
)
Public Shared Sub Grow ( _
    tree As FPTree, _
    alpha As FrequentSet _
)
public:
static void Grow (
    FPTree^ tree,
    FrequentSet^ alpha
)
Parameters
tree (FPTree)
FPtree
alpha (FrequentSet)
Suffix set


MiningAlgorithm Method (MainForm, data, ConclusionList, minsup, minconf, mins, minf, maxanti)

MiningAlgorithm Method (MainForm, data, ConclusionList, minsup, minconf, mins, minf, maxanti)
Namespaces ► Association_mining ► FPGrowth ► MiningAlgorithm(frmMain, Database, List<(Of <Set>)>, Double, Double, Double, Double, Double)
Creates an FPTree based on a given database and performs the FPGrowth algorithm.
Declaration Syntax
C# Visual Basic Visual C++
public static SortableBindingList<Rule> MiningAlgorithm(
    frmMain MainForm,
    Database data,
    List<Set> ConclusionList,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxanti
)
Public Shared Function MiningAlgorithm ( _
    MainForm As frmMain, _
    data As Database, _
    ConclusionList As List(Of Set), _
    minsup As Double, _
    minconf As Double, _
    mins As Double, _
    minf As Double, _
    maxanti As Double _
) As SortableBindingList(Of Rule)
public:
static SortableBindingList<Rule^>^ MiningAlgorithm (
    frmMain^ MainForm,
    Database^ data,
    List<Set^>^ ConclusionList,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxanti
)
Parameters
MainForm (frmMain)
Main program form
data (Database)
Database
ConclusionList (List <(Of <Set>)>)
List of distinct conclusions
minsup (Double)
Minimal support
minconf (Double)
Minimal confidence
mins (Double)
Minimal confirmation-s
minf (Double)
Minimal confirmation-f
maxanti (Double)
Maximal anti-support
Return Value
A list of association rules generated with the FPGrowth algorithm


FPNode Class

FPNode Class
Namespaces ► Association_mining ► FPNode
Class representing an node of an FPTree.
Declaration Syntax
C# Visual Basic Visual C++
public class FPNode
Public Class FPNode
public ref class FPNode
Members
All Members | Constructors | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FPNodeFPNodeNew()() | Default constructor.
 | FPNodeFPNodeNew(String, String, Int32, Int64) | Creates a new node.
 | Id | Node item id.
 | NodeItem | Item in the node.
 | Support | Node support.
Inheritance Hierarchy
Object
FPNode


FPNode Constructor

FPNode Constructor
Namespaces ► Association_mining ► FPNode ► FPNodeFPNodeNew()()
Members
Icon | Member | Description
 | FPNodeFPNodeNew()() | Default constructor.
 | FPNodeFPNodeNew(String, String, Int32, Int64) | Creates a new node.


FPNode Constructor

FPNode Constructor
Namespaces ► Association_mining ► FPNode ► FPNodeFPNodeNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public FPNode()
Public Sub New
public:
FPNode ()


FPNode Constructor (t, n, id, sup)

FPNode Constructor (t, n, id, sup)
Namespaces ► Association_mining ► FPNode ► FPNodeFPNodeNew(String, String, Int32, Int64)
Creates a new node.
Declaration Syntax
C# Visual Basic Visual C++
public FPNode(
    string t,
    string n,
    int id,
    long sup
)
Public Sub New ( _
    t As String, _
    n As String, _
    id As Integer, _
    sup As Long _
)
public:
FPNode (
    String^ t,
    String^ n,
    int id,
    long long sup
)
Parameters
t (String)
Attribute type
n (String)
Attribute name
id (Int32)
Attribute id (database column)
sup (Int64)
Node support


Id Property

Id Property
Namespaces ► Association_mining ► FPNode ► Id
Node item id.
Declaration Syntax
C# Visual Basic Visual C++
public int Id{ get;}
Public ReadOnly Property Id As Integer
public:
property int Id {
    int get ();
}


NodeItem Property

NodeItem Property
Namespaces ► Association_mining ► FPNode ► NodeItem
Item in the node.
Declaration Syntax
C# Visual Basic Visual C++
public Item NodeItem{ get;}
Public ReadOnly Property NodeItem As Item
public:
property Item^ NodeItem {
    Item^ get ();
}


Support Property

Support Property
Namespaces ► Association_mining ► FPNode ► Support
Node support.
Declaration Syntax
C# Visual Basic Visual C++
public long Support{ get; set;}
Public Property Support As Long
public:
property long long Support {
    long long get ();
    void set (long long value);
}


FPTree Class

FPTree Class
Namespaces ► Association_mining ► FPTree
The FPTree class.
Declaration Syntax
C# Visual Basic Visual C++
public class FPTree
Public Class FPTree
public ref class FPTree
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FPTreeFPTreeNew(SortedDictionary<(Of <Int64, Int32>)>) | Constructor. Plants a new FPTree with its header list, based on the given list of item ids sorted by descending support.
 | Add(String, String, Int32, Int64) | Adds a new node to the FPTree. If from the current node being visited there is a child node with the same item then that child is becoming the currently visited node and its support increased by the "added" node support. If there are no child nodes matching the newly added then a new one is created with the support given.
 | GoToRoot()() | Sets the tree root as the currently visited node.
 | IsEmpty | Tells if the tree has any nodes.
 | IsSinglePath | Tells if the tree consists only of a single path.
 | ItemHeader | The header list of the tree.
 | SinglePathNodes()() | Returns a list of nodes in the single path of the tree.
Inheritance Hierarchy
Object
FPTree


FPTree Constructor (sCols)

FPTree Constructor (sCols)
Namespaces ► Association_mining ► FPTree ► FPTreeFPTreeNew(SortedDictionary<(Of <Int64, Int32>)>)
Constructor. Plants a new FPTree with its header list, based on the given list of item ids sorted by descending support.
Declaration Syntax
C# Visual Basic Visual C++
public FPTree(
    SortedDictionary<long, int> sCols
)
Public Sub New ( _
    sCols As SortedDictionary(Of Long, Integer) _
)
public:
FPTree (
    SortedDictionary<long long, int>^ sCols
)
Parameters
sCols (SortedDictionary <(Of < Int64, Int32 >)>)
List of item ids (database columns) sorted by descending support


Add Method (type, name, col, sup)

Add Method (type, name, col, sup)
Namespaces ► Association_mining ► FPTree ► Add(String, String, Int32, Int64)
Adds a new node to the FPTree. If from the current node being visited there is a child node with the same item then that child is becoming the currently visited node and its support increased by the "added" node support. If there are no child nodes matching the newly added then a new one is created with the support given.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string type,
    string name,
    int col,
    long sup
)
Public Sub Add ( _
    type As String, _
    name As String, _
    col As Integer, _
    sup As Long _
)
public:
void Add (
    String^ type,
    String^ name,
    int col,
    long long sup
)
Parameters
type (String)
Item type
name (String)
Item name
col (Int32)
Item id (database column)
sup (Int64)
Node support


GoToRoot Method

GoToRoot Method
Namespaces ► Association_mining ► FPTree ► GoToRoot()()
Sets the tree root as the currently visited node.
Declaration Syntax
C# Visual Basic Visual C++
public void GoToRoot()
Public Sub GoToRoot
public:
void GoToRoot ()


IsEmpty Property

IsEmpty Property
Namespaces ► Association_mining ► FPTree ► IsEmpty
Tells if the tree has any nodes.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEmpty{ get;}
Public ReadOnly Property IsEmpty As Boolean
public:
property bool IsEmpty {
    bool get ();
}


IsSinglePath Property

IsSinglePath Property
Namespaces ► Association_mining ► FPTree ► IsSinglePath
Tells if the tree consists only of a single path.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSinglePath{ get;}
Public ReadOnly Property IsSinglePath As Boolean
public:
property bool IsSinglePath {
    bool get ();
}


ItemHeader Property

ItemHeader Property
Namespaces ► Association_mining ► FPTree ► ItemHeader
The header list of the tree.
Declaration Syntax
C# Visual Basic Visual C++
public Header[] ItemHeader{ get;}
Public ReadOnly Property ItemHeader As Header()
public:
property array<Header^>^ ItemHeader {
    array<Header^>^ get ();
}


SinglePathNodes Method

SinglePathNodes Method
Namespaces ► Association_mining ► FPTree ► SinglePathNodes()()
Returns a list of nodes in the single path of the tree.
Declaration Syntax
C# Visual Basic Visual C++
public Set SinglePathNodes()
Public Function SinglePathNodes As Set
public:
Set^ SinglePathNodes ()
Return Value

[Missing <returns> documentation for M:Association_mining.FPTree.SinglePathNodes]


FrequentSet Class

FrequentSet Class
Namespaces ► Association_mining ► FrequentSet
Class representing a frequent set. That is a set with a known support and universe count (size of the database)
Declaration Syntax
C# Visual Basic Visual C++
public class FrequentSet
Public Class FrequentSet
public ref class FrequentSet
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FrequentSetFrequentSetNew()() | Default constructor.
 | FrequentSetFrequentSetNew(Set, Int64, Int32) | Creates a new frequent set based on a given set, support value and database size.
 | Count | Number of items in the frequent set.
 | Equals(Object) | Overridden equals method allows to compare frequent sets. Frequent sets are said tio be identical if they have the same set of items, support and universe count. (Overrides Object.Equals(Object).)
 | GetHashCode()() | Returns a unique hash value for the frequent set. (Overrides Object.GetHashCode()().)
 | set | The set.
 | Support | Frequent set support.
 | UniverseCount | Universe count.
Inheritance Hierarchy
Object
FrequentSet


FrequentSet Constructor

FrequentSet Constructor
Namespaces ► Association_mining ► FrequentSet ► FrequentSetFrequentSetNew()()
Members
Icon | Member | Description
 | FrequentSetFrequentSetNew()() | Default constructor.
 | FrequentSetFrequentSetNew(Set, Int64, Int32) | Creates a new frequent set based on a given set, support value and database size.


FrequentSet Constructor

FrequentSet Constructor
Namespaces ► Association_mining ► FrequentSet ► FrequentSetFrequentSetNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public FrequentSet()
Public Sub New
public:
FrequentSet ()


FrequentSet Constructor (s, sup, u)

FrequentSet Constructor (s, sup, u)
Namespaces ► Association_mining ► FrequentSet ► FrequentSetFrequentSetNew(Set, Int64, Int32)
Creates a new frequent set based on a given set, support value and database size.
Declaration Syntax
C# Visual Basic Visual C++
public FrequentSet(
    Set s,
    long sup,
    int u
)
Public Sub New ( _
    s As Set, _
    sup As Long, _
    u As Integer _
)
public:
FrequentSet (
    Set^ s,
    long long sup,
    int u
)
Parameters
s (Set)
sup (Int64)
u (Int32)


Count Property

Count Property
Namespaces ► Association_mining ► FrequentSet ► Count
Number of items in the frequent set.
Declaration Syntax
C# Visual Basic Visual C++
public int Count{ get;}
Public ReadOnly Property Count As Integer
public:
property int Count {
    int get ();
}


Equals Method (obj)

Equals Method (obj)
Namespaces ► Association_mining ► FrequentSet ► Equals(Object)
Overridden equals method allows to compare frequent sets. Frequent sets are said tio be identical if they have the same set of items, support and universe count.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals (
    Object^ obj
) override
Parameters
obj (Object)
Return Value
True if frequent sets are identical


GetHashCode Method

GetHashCode Method
Namespaces ► Association_mining ► FrequentSet ► GetHashCode()()
Returns a unique hash value for the frequent set.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode () override
Return Value
Unique hash value for the frequent set


set Field

set Field
Namespaces ► Association_mining ► FrequentSet ► set
The set.
Declaration Syntax
C# Visual Basic Visual C++
public Set set
Public set As Set
public:
Set^ set


Support Field

Support Field
Namespaces ► Association_mining ► FrequentSet ► Support
Frequent set support.
Declaration Syntax
C# Visual Basic Visual C++
public long Support
Public Support As Long
public:
long long Support


UniverseCount Field

UniverseCount Field
Namespaces ► Association_mining ► FrequentSet ► UniverseCount
Universe count.
Declaration Syntax
C# Visual Basic Visual C++
public int UniverseCount
Public UniverseCount As Integer
public:
int UniverseCount


frmMain Class

frmMain Class
Namespaces ► Association_mining ► frmMain
The main program form.
Declaration Syntax
C# Visual Basic Visual C++
public class frmMain : Form
Public Class frmMain _
    Inherits Form
public ref class frmMain : public Form
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | frmMainfrmMainNew()() | Default constructor.
 | DisplayRules(SortableBindingList<(Of <Rule>)>) | Displays rules given in the ruleList parameter.
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | RuleCount | Number of generated rules.
 | RuleGenerationThread()() | Generates rules.
 | Saved()() | Updates status strip elements when rules are saved.
 | SetMaxAnti(Double) |
 | SetMinConf(Double) |
 | SetMinF(Double) |
 | SetMinS(Double) |
 | SetMinSup(Double) |
 | SetRuleCount(Int32) | Sets the rule count value on the status strip.
 | StartGenerationThread()() | Starts a new thread responsible for generating rules.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | frmMain


frmMain Constructor

frmMain Constructor
Namespaces ► Association_mining ► frmMain ► frmMainfrmMainNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public frmMain()
Public Sub New
public:
frmMain ()


DisplayRules Method (ruleList)

DisplayRules Method (ruleList)
Namespaces ► Association_mining ► frmMain ► DisplayRules(SortableBindingList<(Of <Rule>)>)
Displays rules given in the ruleList parameter.
Declaration Syntax
C# Visual Basic Visual C++
public void DisplayRules(
    SortableBindingList<Rule> ruleList
)
Public Sub DisplayRules ( _
    ruleList As SortableBindingList(Of Rule) _
)
public:
void DisplayRules (
    SortableBindingList<Rule^>^ ruleList
)
Parameters
ruleList (SortableBindingList <(Of < Rule >)>)
List of rules to be displayed


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Association_mining ► frmMain ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose (
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


RuleCount Property

RuleCount Property
Namespaces ► Association_mining ► frmMain ► RuleCount
Number of generated rules.
Declaration Syntax
C# Visual Basic Visual C++
public int RuleCount{ get;}
Public ReadOnly Property RuleCount As Integer
public:
property int RuleCount {
    int get ();
}


RuleGenerationThread Method

RuleGenerationThread Method
Namespaces ► Association_mining ► frmMain ► RuleGenerationThread()()
Generates rules.
Declaration Syntax
C# Visual Basic Visual C++
public void RuleGenerationThread()
Public Sub RuleGenerationThread
public:
void RuleGenerationThread ()


Saved Method

Saved Method
Namespaces ► Association_mining ► frmMain ► Saved()()
Updates status strip elements when rules are saved.
Declaration Syntax
C# Visual Basic Visual C++
public void Saved()
Public Sub Saved
public:
void Saved ()


SetMaxAnti Method (m)

SetMaxAnti Method (m)
Namespaces ► Association_mining ► frmMain ► SetMaxAnti(Double)

[Missing <summary> documentation for M:Association_mining.frmMain.SetMaxAnti(System.Double)]

Declaration Syntax
C# Visual Basic Visual C++
internal void SetMaxAnti(
    double m
)
Friend Sub SetMaxAnti ( _
    m As Double _
)
internal:
void SetMaxAnti (
    double m
)
Parameters
m (Double)


SetMinConf Method (m)

SetMinConf Method (m)
Namespaces ► Association_mining ► frmMain ► SetMinConf(Double)

[Missing <summary> documentation for M:Association_mining.frmMain.SetMinConf(System.Double)]

Declaration Syntax
C# Visual Basic Visual C++
internal void SetMinConf(
    double m
)
Friend Sub SetMinConf ( _
    m As Double _
)
internal:
void SetMinConf (
    double m
)
Parameters
m (Double)


SetMinF Method (m)

SetMinF Method (m)
Namespaces ► Association_mining ► frmMain ► SetMinF(Double)

[Missing <summary> documentation for M:Association_mining.frmMain.SetMinF(System.Double)]

Declaration Syntax
C# Visual Basic Visual C++
internal void SetMinF(
    double m
)
Friend Sub SetMinF ( _
    m As Double _
)
internal:
void SetMinF (
    double m
)
Parameters
m (Double)


SetMinS Method (m)

SetMinS Method (m)
Namespaces ► Association_mining ► frmMain ► SetMinS(Double)

[Missing <summary> documentation for M:Association_mining.frmMain.SetMinS(System.Double)]

Declaration Syntax
C# Visual Basic Visual C++
internal void SetMinS(
    double m
)
Friend Sub SetMinS ( _
    m As Double _
)
internal:
void SetMinS (
    double m
)
Parameters
m (Double)


SetMinSup Method (minSup)

SetMinSup Method (minSup)
Namespaces ► Association_mining ► frmMain ► SetMinSup(Double)

[Missing <summary> documentation for M:Association_mining.frmMain.SetMinSup(System.Double)]

Declaration Syntax
C# Visual Basic Visual C++
internal void SetMinSup(
    double minSup
)
Friend Sub SetMinSup ( _
    minSup As Double _
)
internal:
void SetMinSup (
    double minSup
)
Parameters
minSup (Double)


SetRuleCount Method (value)

SetRuleCount Method (value)
Namespaces ► Association_mining ► frmMain ► SetRuleCount(Int32)
Sets the rule count value on the status strip.
Declaration Syntax
C# Visual Basic Visual C++
public void SetRuleCount(
    int value
)
Public Sub SetRuleCount ( _
    value As Integer _
)
public:
void SetRuleCount (
    int value
)
Parameters
value (Int32)
Rule count


StartGenerationThread Method

StartGenerationThread Method
Namespaces ► Association_mining ► frmMain ► StartGenerationThread()()
Starts a new thread responsible for generating rules.
Declaration Syntax
C# Visual Basic Visual C++
public void StartGenerationThread()
Public Sub StartGenerationThread
public:
void StartGenerationThread ()


Header Class

Header Class
Namespaces ► Association_mining ► Header
A header structure allowing to quickly localize all th nodes with the same item.
Declaration Syntax
C# Visual Basic Visual C++
public class Header
Public Class Header
public ref class Header
Members
All Members | Constructors | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HeaderHeaderNew(Int32, Int64) | Creates a new header for the given item.
 | Id | Item id.
 | ItemList | List of items with the same item.
 | Supp | Item support (not node support).
Inheritance Hierarchy
Object
Header


Header Constructor (id, supp)

Header Constructor (id, supp)
Namespaces ► Association_mining ► Header ► HeaderHeaderNew(Int32, Int64)
Creates a new header for the given item.
Declaration Syntax
C# Visual Basic Visual C++
public Header(
    int id,
    long supp
)
Public Sub New ( _
    id As Integer, _
    supp As Long _
)
public:
Header (
    int id,
    long long supp
)
Parameters
id (Int32)
Item id
supp (Int64)
Item support


Id Field

Id Field
Namespaces ► Association_mining ► Header ► Id
Item id.
Declaration Syntax
C# Visual Basic Visual C++
public int Id
Public Id As Integer
public:
int Id


ItemList Field

ItemList Field
Namespaces ► Association_mining ► Header ► ItemList
List of items with the same item.
Declaration Syntax
C# Visual Basic Visual C++
public List<GeneralTree<FPNode>> ItemList
Public ItemList As List(Of GeneralTree(Of FPNode))
public:
List<GeneralTree<FPNode^>^>^ ItemList


Supp Field

Supp Field
Namespaces ► Association_mining ► Header ► Supp
Item support (not node support).
Declaration Syntax
C# Visual Basic Visual C++
public long Supp
Public Supp As Long
public:
long long Supp


frmMain.IntThreadCallback Delegate

frmMain..::IntThreadCallback Delegate
Namespaces ► Association_mining ► frmMain ► frmMain..::IntThreadCallback
A delegate used invoke functions with one int parameter by a background thread.
Declaration Syntax
C# Visual Basic Visual C++
private delegate void IntThreadCallback(
    int i
)
Private Delegate Sub IntThreadCallback ( _
    i As Integer _
)
private delegate void IntThreadCallback (
    int i
)
Parameters
i (Int32)
A number


Item Class

Item Class
Namespaces ► Association_mining ► Item
A class representing a single item. As an item we understand a unique pair of an attribute type and name.
Declaration Syntax
C# Visual Basic Visual C++
public class Item
Public Class Item
public ref class Item
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemItemNew()() | Default constructor.
 | ItemItemNew(String, String) | Creates a new item.
 | Equals(Object) | Overridden equals method allows to compare items. Items are said to be equal if they have identical Type and Name values. (Overrides Object.Equals(Object).)
 | GetHashCode()() | Returns a unique hash value based on the item type and name. (Overrides Object.GetHashCode()().)
 | Name | Attribute name.
 | Type | Attribute type.
Inheritance Hierarchy
Object
Item


Item Constructor

Item Constructor
Namespaces ► Association_mining ► Item ► ItemItemNew()()
Members
Icon | Member | Description
 | ItemItemNew()() | Default constructor.
 | ItemItemNew(String, String) | Creates a new item.


Item Constructor

Item Constructor
Namespaces ► Association_mining ► Item ► ItemItemNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public Item()
Public Sub New
public:
Item ()


Item Constructor (t, n)

Item Constructor (t, n)
Namespaces ► Association_mining ► Item ► ItemItemNew(String, String)
Creates a new item.
Declaration Syntax
C# Visual Basic Visual C++
public Item(
    string t,
    string n
)
Public Sub New ( _
    t As String, _
    n As String _
)
public:
Item (
    String^ t,
    String^ n
)
Parameters
t (String)
Type
n (String)
Name


Equals Method (obj)

Equals Method (obj)
Namespaces ► Association_mining ► Item ► Equals(Object)
Overridden equals method allows to compare items. Items are said to be equal if they have identical Type and Name values.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals (
    Object^ obj
) override
Parameters
obj (Object)
Return Value
True if items are identical and false if they are not identical


GetHashCode Method

GetHashCode Method
Namespaces ► Association_mining ► Item ► GetHashCode()()
Returns a unique hash value based on the item type and name.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode () override
Return Value
A unique value representing an item


Name Field

Name Field
Namespaces ► Association_mining ► Item ► Name
Attribute name.
Declaration Syntax
C# Visual Basic Visual C++
public string Name
Public Name As String
public:
String^ Name


Type Field

Type Field
Namespaces ► Association_mining ► Item ► Type
Attribute type.
Declaration Syntax
C# Visual Basic Visual C++
public string Type
Public Type As String
public:
String^ Type


MinSupp Class

MinSupp Class
Namespaces ► Association_mining ► MinSupp
Provides an interface to provide minimal measure values required later to generate rules.
Declaration Syntax
C# Visual Basic Visual C++
public class MinSupp : Form
Public Class MinSupp _
    Inherits Form
public ref class MinSupp : public Form
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MinSuppMinSuppNew(frmMain) | Constructor.
 | Cancel_Click(Object, EventArgs) | Destroys the form.
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | OK_Click(Object, EventArgs) | Starts the rule generation thread if the values provided by the user are correct.
 | textBox1 |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | MinSupp


MinSupp Constructor (parent)

MinSupp Constructor (parent)
Namespaces ► Association_mining ► MinSupp ► MinSuppMinSuppNew(frmMain)
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public MinSupp(
    frmMain parent
)
Public Sub New ( _
    parent As frmMain _
)
public:
MinSupp (
    frmMain^ parent
)
Parameters
parent (frmMain)
Parent form


Cancel_Click Method (sender, e)

Cancel_Click Method (sender, e)
Namespaces ► Association_mining ► MinSupp ► Cancel_Click(Object, EventArgs)
Destroys the form.
Declaration Syntax
C# Visual Basic Visual C++
protected void Cancel_Click(
    Object sender,
    EventArgs e
)
Protected Sub Cancel_Click ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void Cancel_Click (
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Association_mining ► MinSupp ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose (
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


OK_Click Method (sender, e)

OK_Click Method (sender, e)
Namespaces ► Association_mining ► MinSupp ► OK_Click(Object, EventArgs)
Starts the rule generation thread if the values provided by the user are correct.
Declaration Syntax
C# Visual Basic Visual C++
protected void OK_Click(
    Object sender,
    EventArgs e
)
Protected Sub OK_Click ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void OK_Click (
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


textBox1 Field

textBox1 Field
Namespaces ► Association_mining ► MinSupp ► textBox1

[Missing <summary> documentation for F:Association_mining.MinSupp.textBox1]

Declaration Syntax
C# Visual Basic Visual C++
public TextBox textBox1
Public textBox1 As TextBox
public:
TextBox^ textBox1


MultiChart Class

MultiChart Class
Namespaces ► Association_mining ► MultiChart
The multi chart class.
Declaration Syntax
C# Visual Basic Visual C++
public class MultiChart : Form
Public Class MultiChart _
    Inherits Form
public ref class MultiChart : public Form
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiChartMultiChartNew()() | Default constructor.
 | MultiChartMultiChartNew(List<(Of <Rule>)>, Double, Double, Double, Double, Double) | Creates a new multichart object based on the given rules and minimal support
 | AddToGrid(Rule) | Adds a rule to the datagrid.
 | button1_Click(Object, EventArgs) | Saves the chart in *.bmp format.
 | CalculateMinValues()() | Paints the multichart.
 | Change(Object, EventArgs) | Forces the chart to repaint itself.
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)
 | Mouse_Down(Object, MouseEventArgs) | Starts drawing the lasso.
 | Mouse_Move(Object, MouseEventArgs) | Draws the lasso.
 | Mouse_Up(Object, MouseEventArgs) | Closes the lasso.
 | PaintCharts()() | Refreshes the multichart.
 | pboxPaint(Object, PaintEventArgs) | Paints a single chart depending on the sender.
 | tboxSup |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | Form
 |  |  |  |  |  |  | MultiChart


MultiChart Constructor

MultiChart Constructor
Namespaces ► Association_mining ► MultiChart ► MultiChartMultiChartNew()()
Members
Icon | Member | Description
 | MultiChartMultiChartNew()() | Default constructor.
 | MultiChartMultiChartNew(List<(Of <Rule>)>, Double, Double, Double, Double, Double) | Creates a new multichart object based on the given rules and minimal support


MultiChart Constructor

MultiChart Constructor
Namespaces ► Association_mining ► MultiChart ► MultiChartMultiChartNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public MultiChart()
Public Sub New
public:
MultiChart ()


MultiChart Constructor (ruleList, minsup, minconf, mins, minf, maxa)

MultiChart Constructor (ruleList, minsup, minconf, mins, minf, maxa)
Namespaces ► Association_mining ► MultiChart ► MultiChartMultiChartNew(List<(Of <Rule>)>, Double, Double, Double, Double, Double)
Creates a new multichart object based on the given rules and minimal support
Declaration Syntax
C# Visual Basic Visual C++
public MultiChart(
    List<Rule> ruleList,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxa
)
Public Sub New ( _
    ruleList As List(Of Rule), _
    minsup As Double, _
    minconf As Double, _
    mins As Double, _
    minf As Double, _
    maxa As Double _
)
public:
MultiChart (
    List<Rule^>^ ruleList,
    double minsup,
    double minconf,
    double mins,
    double minf,
    double maxa
)
Parameters
ruleList (List <(Of < Rule >)>)
List of rules with the same conclusion
minsup (Double)
Absolute minimal support
minconf (Double)
Minimal confidence
mins (Double)
Minimal confirmation-s
minf (Double)
Minimal confirmation-f
maxa (Double)
Maximal anti-support


AddToGrid Method (r)

AddToGrid Method (r)
Namespaces ► Association_mining ► MultiChart ► AddToGrid(Rule)
Adds a rule to the datagrid.
Declaration Syntax
C# Visual Basic Visual C++
protected void AddToGrid(
    Rule r
)
Protected Sub AddToGrid ( _
    r As Rule _
)
protected:
void AddToGrid (
    Rule^ r
)
Parameters
r (Rule)
Rule to be added to the datagrid


button1_Click Method (sender, e)

button1_Click Method (sender, e)
Namespaces ► Association_mining ► MultiChart ► button1_Click(Object, EventArgs)
Saves the chart in *.bmp format.
Declaration Syntax
C# Visual Basic Visual C++
protected void button1_Click(
    Object sender,
    EventArgs e
)
Protected Sub button1_Click ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void button1_Click (
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


CalculateMinValues Method

CalculateMinValues Method
Namespaces ► Association_mining ► MultiChart ► CalculateMinValues()()
Paints the multichart.
Declaration Syntax
C# Visual Basic Visual C++
protected void CalculateMinValues()
Protected Sub CalculateMinValues
protected:
void CalculateMinValues ()


Change Method (sender, e)

Change Method (sender, e)
Namespaces ► Association_mining ► MultiChart ► Change(Object, EventArgs)
Forces the chart to repaint itself.
Declaration Syntax
C# Visual Basic Visual C++
protected void Change(
    Object sender,
    EventArgs e
)
Protected Sub Change ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void Change (
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Association_mining ► MultiChart ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose (
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.


Mouse_Down Method (sender, e)

Mouse_Down Method (sender, e)
Namespaces ► Association_mining ► MultiChart ► Mouse_Down(Object, MouseEventArgs)
Starts drawing the lasso.
Declaration Syntax
C# Visual Basic Visual C++
protected void Mouse_Down(
    Object sender,
    MouseEventArgs e
)
Protected Sub Mouse_Down ( _
    sender As Object, _
    e As MouseEventArgs _
)
protected:
void Mouse_Down (
    Object^ sender,
    MouseEventArgs^ e
)
Parameters
sender (Object)
e (MouseEventArgs)


Mouse_Move Method (sender, e)

Mouse_Move Method (sender, e)
Namespaces ► Association_mining ► MultiChart ► Mouse_Move(Object, MouseEventArgs)
Draws the lasso.
Declaration Syntax
C# Visual Basic Visual C++
protected void Mouse_Move(
    Object sender,
    MouseEventArgs e
)
Protected Sub Mouse_Move ( _
    sender As Object, _
    e As MouseEventArgs _
)
protected:
void Mouse_Move (
    Object^ sender,
    MouseEventArgs^ e
)
Parameters
sender (Object)
e (MouseEventArgs)


Mouse_Up Method (sender, e)

Mouse_Up Method (sender, e)
Namespaces ► Association_mining ► MultiChart ► Mouse_Up(Object, MouseEventArgs)
Closes the lasso.
Declaration Syntax
C# Visual Basic Visual C++
protected void Mouse_Up(
    Object sender,
    MouseEventArgs e
)
Protected Sub Mouse_Up ( _
    sender As Object, _
    e As MouseEventArgs _
)
protected:
void Mouse_Up (
    Object^ sender,
    MouseEventArgs^ e
)
Parameters
sender (Object)
e (MouseEventArgs)


PaintCharts Method

PaintCharts Method
Namespaces ► Association_mining ► MultiChart ► PaintCharts()()
Refreshes the multichart.
Declaration Syntax
C# Visual Basic Visual C++
protected void PaintCharts()
Protected Sub PaintCharts
protected:
void PaintCharts ()


pboxPaint Method (sender, e)

pboxPaint Method (sender, e)
Namespaces ► Association_mining ► MultiChart ► pboxPaint(Object, PaintEventArgs)
Paints a single chart depending on the sender.
Declaration Syntax
C# Visual Basic Visual C++
protected void pboxPaint(
    Object sender,
    PaintEventArgs e
)
Protected Sub pboxPaint ( _
    sender As Object, _
    e As PaintEventArgs _
)
protected:
void pboxPaint (
    Object^ sender,
    PaintEventArgs^ e
)
Parameters
sender (Object)
e (PaintEventArgs)


tboxSup Field

tboxSup Field
Namespaces ► Association_mining ► MultiChart ► tboxSup

[Missing <summary> documentation for F:Association_mining.MultiChart.tboxSup]

Declaration Syntax
C# Visual Basic Visual C++
internal TextBox tboxSup
Friend tboxSup As TextBox
internal:
TextBox^ tboxSup


Program Class

Program Class
Namespaces ► Association_mining ► Program
Class responsoible for starting and running the program.
Declaration Syntax
C# Visual Basic Visual C++
internal static class Program
Friend NotInheritable Class Program
internal ref class Program abstract sealed
Inheritance Hierarchy
Object
Program


RecordHolder Class

RecordHolder Class
Namespaces ► Association_mining ► RecordHolder
Class responsible for creating databases and holding there logical structure.
Declaration Syntax
C# Visual Basic Visual C++
public class RecordHolder
Public Class RecordHolder
public ref class RecordHolder
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecordHolderRecordHolderNew(array<String>[](), array<String>[]()) | Constructor. Creates a new REcordHolder based on the given set of types and names.
 | AttributeCount | Array of long representing the support of each atribute (column) in the database.
 | AttributeSupport(Int32) | Returns support for the specified attribute
 | DistinctTypes | Array of distinct attribute type names.
 | NameCount | Number of names.
 | Names | Array of attribute names.
 | TypeCount | Number of distinct types.
 | Types | Array of attribute type names.
Inheritance Hierarchy
Object
RecordHolder


RecordHolder Constructor (AttrNamesDef, AttrTypesDef)

RecordHolder Constructor (AttrNamesDef, AttrTypesDef)
Namespaces ► Association_mining ► RecordHolder ► RecordHolderRecordHolderNew(array<String>[](), array<String>[]())
Constructor. Creates a new REcordHolder based on the given set of types and names.
Declaration Syntax
C# Visual Basic Visual C++
public RecordHolder(
    string[] AttrNamesDef,
    string[] AttrTypesDef
)
Public Sub New ( _
    AttrNamesDef As String(), _
    AttrTypesDef As String() _
)
public:
RecordHolder (
    array<String^>^ AttrNamesDef,
    array<String^>^ AttrTypesDef
)
Parameters
AttrNamesDef (array< String >[]())
Array of attribute names
AttrTypesDef (array< String >[]())
Array of attribute types


AttributeCount Field

AttributeCount Field
Namespaces ► Association_mining ► RecordHolder ► AttributeCount
Array of long representing the support of each atribute (column) in the database.
Declaration Syntax
C# Visual Basic Visual C++
public long[] AttributeCount
Public AttributeCount As Long()
public:
array<long long>^ AttributeCount


AttributeSupport Method (idx)

AttributeSupport Method (idx)
Namespaces ► Association_mining ► RecordHolder ► AttributeSupport(Int32)
Returns support for the specified attribute
Declaration Syntax
C# Visual Basic Visual C++
public long AttributeSupport(
    int idx
)
Public Function AttributeSupport ( _
    idx As Integer _
) As Long
public:
long long AttributeSupport (
    int idx
)
Parameters
idx (Int32)
Column index
Return Value
The support of the attribte in column idx in the database


DistinctTypes Property

DistinctTypes Property
Namespaces ► Association_mining ► RecordHolder ► DistinctTypes
Array of distinct attribute type names.
Declaration Syntax
C# Visual Basic Visual C++
public string[] DistinctTypes{ get;}
Public ReadOnly Property DistinctTypes As String()
public:
property array<String^>^ DistinctTypes {
    array<String^>^ get ();
}


NameCount Property

NameCount Property
Namespaces ► Association_mining ► RecordHolder ► NameCount
Number of names.
Declaration Syntax
C# Visual Basic Visual C++
public int NameCount{ get;}
Public ReadOnly Property NameCount As Integer
public:
property int NameCount {
    int get ();
}


Names Property

Names Property
Namespaces ► Association_mining ► RecordHolder ► Names
Array of attribute names.
Declaration Syntax
C# Visual Basic Visual C++
public string[] Names{ get;}
Public ReadOnly Property Names As String()
public:
property array<String^>^ Names {
    array<String^>^ get ();
}


TypeCount Property

TypeCount Property
Namespaces ► Association_mining ► RecordHolder ► TypeCount
Number of distinct types.
Declaration Syntax
C# Visual Basic Visual C++
public int TypeCount{ get; set;}
Public Property TypeCount As Integer
public:
property int TypeCount {
    int get ();
    void set (int value);
}


Types Property

Types Property
Namespaces ► Association_mining ► RecordHolder ► Types
Array of attribute type names.
Declaration Syntax
C# Visual Basic Visual C++
public string[] Types{ get;}
Public ReadOnly Property Types As String()
public:
property array<String^>^ Types {
    array<String^>^ get ();
}


Rule Class

Rule Class
Namespaces ► Association_mining ► Rule
Rule class. Contains all the nesesary information about a rule like it's support, confidence, confirmation and others.
Declaration Syntax
C# Visual Basic Visual C++
public class Rule
Public Class Rule
public ref class Rule
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RuleRuleNew()() | Default constructor.
 | RuleRuleNew(Set, Set, Int64, Int64, Int64, Int64) | Creates a new rule.
 | RuleRuleNew(Set, Set, Int64, Int64, Int64, Int64, Int32) | Creates a new rule.
 | a | The "a" value. Number of rules in the database where E and H.
 | AntiSupport | Rule anti-support.
 | b | The "b" value. Number of rules in the database where ~E andH
 | c | The "c" value. Number of rules in the database where E and ~H
 | conclusion | String translation of the hipothesis part of the rule.
 | Confidence | Rule confidence.
 | d | The "d" value. Number of rules in the database where ~E and ~H
 | E | Evidence part of the rule.
 | EqualSupportCount | Number of rules with the same support and conclusion. This property is required to achieve minimal cost while searching for pareto rules.
 | F | Confirmation-f of the rule.
 | GetPivot(List<(Of <Rule>)>, Int32, Int32) | Used to find the pivot point for quicksort
 | H | Hipothesis part of the rule.
 | premise | A string version of the evidence part of the rule.
 | QuickSort(List<(Of <Rule>)>, Int32, Int32) | Quicksort method used to sort rules.
 | S | Confirmation-s of the rule.
 | SortStructure(List<(Of <List<(Of <Rule>)>>)>) | Sorts the rule structure descending by support and ascending by anti-support.
 | Support | Rule support.
 | Swap(List<(Of <Rule>)>, Int32, Int32) | Swaps two rules.
 | Transform(SortableBindingList<(Of <Rule>)>, List<(Of <Set>)>) | Transforms a list of unordered rules into a rule structure where rules with the same xconclusion are on a seperate list sorted descending by support and ascending by anti-support. Each rule in the structure knows the next cell with a different support.
Inheritance Hierarchy
Object
Rule


Rule Constructor

Rule Constructor
Namespaces ► Association_mining ► Rule ► RuleRuleNew()()
Members
Icon | Member | Description
 | RuleRuleNew()() | Default constructor.
 | RuleRuleNew(Set, Set, Int64, Int64, Int64, Int64) | Creates a new rule.
 | RuleRuleNew(Set, Set, Int64, Int64, Int64, Int64, Int32) | Creates a new rule.


Rule Constructor

Rule Constructor
Namespaces ► Association_mining ► Rule ► RuleRuleNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public Rule()
Public Sub New
public:
Rule ()


Rule Constructor (e, h, u, w, x, y)

Rule Constructor (e, h, u, w, x, y)
Namespaces ► Association_mining ► Rule ► RuleRuleNew(Set, Set, Int64, Int64, Int64, Int64)
Creates a new rule.
Declaration Syntax
C# Visual Basic Visual C++
public Rule(
    Set e,
    Set h,
    long u,
    long w,
    long x,
    long y
)
Public Sub New ( _
    e As Set, _
    h As Set, _
    u As Long, _
    w As Long, _
    x As Long, _
    y As Long _
)
public:
Rule (
    Set^ e,
    Set^ h,
    long long u,
    long long w,
    long long x,
    long long y
)
Parameters
e (Set)
Evidence
h (Set)
Hipothesis
u (Int64)
a value
w (Int64)
b value
x (Int64)
c balue
y (Int64)
d value


Rule Constructor (e, h, u, w, x, y, equalCount)

Rule Constructor (e, h, u, w, x, y, equalCount)
Namespaces ► Association_mining ► Rule ► RuleRuleNew(Set, Set, Int64, Int64, Int64, Int64, Int32)
Creates a new rule.
Declaration Syntax
C# Visual Basic Visual C++
public Rule(
    Set e,
    Set h,
    long u,
    long w,
    long x,
    long y,
    int equalCount
)
Public Sub New ( _
    e As Set, _
    h As Set, _
    u As Long, _
    w As Long, _
    x As Long, _
    y As Long, _
    equalCount As Integer _
)
public:
Rule (
    Set^ e,
    Set^ h,
    long long u,
    long long w,
    long long x,
    long long y,
    int equalCount
)
Parameters
e (Set)
Evidence
h (Set)
Hipothesis
u (Int64)
a value
w (Int64)
b value
x (Int64)
c balue
y (Int64)
d value
equalCount (Int32)
Number of rules with the same support and conclusion


a Field

a Field
Namespaces ► Association_mining ► Rule ► a
The "a" value. Number of rules in the database where E and H.
Declaration Syntax
C# Visual Basic Visual C++
public long a
Public a As Long
public:
long long a


AntiSupport Property

AntiSupport Property
Namespaces ► Association_mining ► Rule ► AntiSupport
Rule anti-support.
Declaration Syntax
C# Visual Basic Visual C++
public double AntiSupport{ get; set;}
Public Property AntiSupport As Double
public:
property double AntiSupport {
    double get ();
    void set (double value);
}


b Field

b Field
Namespaces ► Association_mining ► Rule ► b
The "b" value. Number of rules in the database where ~E andH
Declaration Syntax
C# Visual Basic Visual C++
public long b
Public b As Long
public:
long long b


c Field

c Field
Namespaces ► Association_mining ► Rule ► c
The "c" value. Number of rules in the database where E and ~H
Declaration Syntax
C# Visual Basic Visual C++
public long c
Public c As Long
public:
long long c


conclusion Property

conclusion Property
Namespaces ► Association_mining ► Rule ► conclusion
String translation of the hipothesis part of the rule.
Declaration Syntax
C# Visual Basic Visual C++
public string conclusion{ get;}
Public ReadOnly Property conclusion As String
public:
property String^ conclusion {
    String^ get ();
}


Confidence Property

Confidence Property
Namespaces ► Association_mining ► Rule ► Confidence
Rule confidence.
Declaration Syntax
C# Visual Basic Visual C++
public double Confidence{ get; set;}
Public Property Confidence As Double
public:
property double Confidence {
    double get ();
    void set (double value);
}


d Field

d Field
Namespaces ► Association_mining ► Rule ► d
The "d" value. Number of rules in the database where ~E and ~H
Declaration Syntax
C# Visual Basic Visual C++
public long d
Public d As Long
public:
long long d


E Property

E Property
Namespaces ► Association_mining ► Rule ► E
Evidence part of the rule.
Declaration Syntax
C# Visual Basic Visual C++
internal Set E{ get;}
Friend ReadOnly Property E As Set
internal:
property Set^ E {
    Set^ get ();
}


EqualSupportCount Property

EqualSupportCount Property
Namespaces ► Association_mining ► Rule ► EqualSupportCount
Number of rules with the same support and conclusion. This property is required to achieve minimal cost while searching for pareto rules.
Declaration Syntax
C# Visual Basic Visual C++
public int EqualSupportCount{ get; set;}
Public Property EqualSupportCount As Integer
public:
property int EqualSupportCount {
    int get ();
    void set (int value);
}


F Property

F Property
Namespaces ► Association_mining ► Rule ► F
Confirmation-f of the rule.
Declaration Syntax
C# Visual Basic Visual C++
public double F{ get; set;}
Public Property F As Double
public:
property double F {
    double get ();
    void set (double value);
}


GetPivot Method (list, leftBoundary, rightBoundary)

GetPivot Method (list, leftBoundary, rightBoundary)
Namespaces ► Association_mining ► Rule ► GetPivot(List<(Of <Rule>)>, Int32, Int32)
Used to find the pivot point for quicksort
Declaration Syntax
C# Visual Basic Visual C++
protected static int GetPivot(
    List<Rule> list,
    int leftBoundary,
    int rightBoundary
)
Protected Shared Function GetPivot ( _
    list As List(Of Rule), _
    leftBoundary As Integer, _
    rightBoundary As Integer _
) As Integer
protected:
static int GetPivot (
    List<Rule^>^ list,
    int leftBoundary,
    int rightBoundary
)
Parameters
list (List <(Of < Rule >)>)
Rule list
leftBoundary (Int32)
Left boundary of the list to sort
rightBoundary (Int32)
Right boundary of the list to sort
Return Value
Index of the element to become the pivot point for quicksort


H Property

H Property
Namespaces ► Association_mining ► Rule ► H
Hipothesis part of the rule.
Declaration Syntax
C# Visual Basic Visual C++
internal Set H{ get;}
Friend ReadOnly Property H As Set
internal:
property Set^ H {
    Set^ get ();
}


premise Property

premise Property
Namespaces ► Association_mining ► Rule ► premise
A string version of the evidence part of the rule.
Declaration Syntax
C# Visual Basic Visual C++
public string premise{ get;}
Public ReadOnly Property premise As String
public:
property String^ premise {
    String^ get ();
}


QuickSort Method (list, leftBoundary, rightBoundary)

QuickSort Method (list, leftBoundary, rightBoundary)
Namespaces ► Association_mining ► Rule ► QuickSort(List<(Of <Rule>)>, Int32, Int32)
Quicksort method used to sort rules.
Declaration Syntax
C# Visual Basic Visual C++
protected static void QuickSort(
    List<Rule> list,
    int leftBoundary,
    int rightBoundary
)
Protected Shared Sub QuickSort ( _
    list As List(Of Rule), _
    leftBoundary As Integer, _
    rightBoundary As Integer _
)
protected:
static void QuickSort (
    List<Rule^>^ list,
    int leftBoundary,
    int rightBoundary
)
Parameters
list (List <(Of < Rule >)>)
Rule list
leftBoundary (Int32)
Left boundary of the list to sort
rightBoundary (Int32)
Right boundary of the list to sort


S Property

S Property
Namespaces ► Association_mining ► Rule ► S
Confirmation-s of the rule.
Declaration Syntax
C# Visual Basic Visual C++
public double S{ get; set;}
Public Property S As Double
public:
property double S {
    double get ();
    void set (double value);
}


SortStructure Method (structure)

SortStructure Method (structure)
Namespaces ► Association_mining ► Rule ► SortStructure(List<(Of <List<(Of <Rule>)>>)>)
Sorts the rule structure descending by support and ascending by anti-support.
Declaration Syntax
C# Visual Basic Visual C++
public static void SortStructure(
    List<List<Rule>> structure
)
Public Shared Sub SortStructure ( _
    structure As List(Of List(Of Rule)) _
)
public:
static void SortStructure (
    List<List<Rule^>^>^ structure
)
Parameters
structure (List <(Of < List <(Of < Rule >)>>)>)
Rule structure


Support Property

Support Property
Namespaces ► Association_mining ► Rule ► Support
Rule support.
Declaration Syntax
C# Visual Basic Visual C++
public double Support{ get; set;}
Public Property Support As Double
public:
property double Support {
    double get ();
    void set (double value);
}


Swap Method (list, pos1, pos2)

Swap Method (list, pos1, pos2)
Namespaces ► Association_mining ► Rule ► Swap(List<(Of <Rule>)>, Int32, Int32)
Swaps two rules.
Declaration Syntax
C# Visual Basic Visual C++
protected static void Swap(
    List<Rule> list,
    int pos1,
    int pos2
)
Protected Shared Sub Swap ( _
    list As List(Of Rule), _
    pos1 As Integer, _
    pos2 As Integer _
)
protected:
static void Swap (
    List<Rule^>^ list,
    int pos1,
    int pos2
)
Parameters
list (List <(Of < Rule >)>)
Rule list
pos1 (Int32)
First rule
pos2 (Int32)
Second rule


Transform Method (ruleList, ConclusionList)

Transform Method (ruleList, ConclusionList)
Namespaces ► Association_mining ► Rule ► Transform(SortableBindingList<(Of <Rule>)>, List<(Of <Set>)>)
Transforms a list of unordered rules into a rule structure where rules with the same xconclusion are on a seperate list sorted descending by support and ascending by anti-support. Each rule in the structure knows the next cell with a different support.
Declaration Syntax
C# Visual Basic Visual C++
public static List<List<Rule>> Transform(
    SortableBindingList<Rule> ruleList,
    List<Set> ConclusionList
)
Public Shared Function Transform ( _
    ruleList As SortableBindingList(Of Rule), _
    ConclusionList As List(Of Set) _
) As List(Of List(Of Rule))
public:
static List<List<Rule^>^>^ Transform (
    SortableBindingList<Rule^>^ ruleList,
    List<Set^>^ ConclusionList
)
Parameters
ruleList (SortableBindingList <(Of < Rule >)>)
List of all the rules
ConclusionList (List <(Of <Set>)>)
List of distinct conclusions
Return Value
A rule structure


RuleComparer Class

RuleComparer Class
Namespaces ► Association_mining ► RuleComparer

[Missing <summary> documentation for T:Association_mining.RuleComparer]

Declaration Syntax
C# Visual Basic Visual C++
internal class RuleComparer : IComparer<Rule>
Friend Class RuleComparer _
    Implements IComparer(Of Rule)
internal ref class RuleComparer : IComparer<Rule^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RuleComparerRuleComparerNew()() |
 | Compare(Rule, Rule) |
Inheritance Hierarchy
Object
RuleComparer


RuleComparer Constructor

RuleComparer Constructor
Namespaces ► Association_mining ► RuleComparer ► RuleComparerRuleComparerNew()()
Initializes a new instance of the RuleComparer class.
Declaration Syntax
C# Visual Basic Visual C++
public RuleComparer()
Public Sub New
public:
RuleComparer ()


Compare Method (r1, r2)

Compare Method (r1, r2)
Namespaces ► Association_mining ► RuleComparer ► Compare(Rule, Rule)

[Missing <summary> documentation for M:Association_mining.RuleComparer.Compare(Association_mining.Rule,Association_mining.Rule)]

Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    Rule r1,
    Rule r2
)
Public Function Compare ( _
    r1 As Rule, _
    r2 As Rule _
) As Integer
public:
virtual int Compare (
    Rule^ r1,
    Rule^ r2
) sealed
Parameters
r1 (Rule)
r2 (Rule)
Return Value

[Missing <returns> documentation for M:Association_mining.RuleComparer.Compare(Association_mining.Rule,Association_mining.Rule)]


SetUtil Class

SetUtil Class
Namespaces ► Association_mining ► SetUtil
A static class providing basic functions that operate on sets. This includes rule generation, creation of subsets, parsing sets to strings etc.
Declaration Syntax
C# Visual Basic Visual C++
public static class SetUtil
Public NotInheritable Class SetUtil
public ref class SetUtil abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CheckSupport(Set, List<(Of <FrequentSet>)>, Database) | Chaecks the support of a given (frequent) set.
 | GenerateCandidateSets(List<(Of <Set>)>) | Generates candidate sets from a given list of sets.
 | GenerateRules(frmMain, Database, List<(Of <Set>)>, List<(Of <FrequentSet>)>, Double, Double, Double, Double) | Generates rules from a list of frequent sets.
 | GenerateTransitionVector(Int32) | Generates a Johnson code transition vector used to find all subsets.
 | HasDistinctTypes(Set) | Checks if all the items in the given set are of different types.
 | ParseEvidence(Rule) | Transform the rules evidence from set form to a string.
 | ParseHipothesis(Rule) | Transform the rules hipothesis from set form to a string.
 | ParseSet(Set) | Transform from set form to a string.
 | SubsetMinusOne(Set) | Generates a list of subsets with a count htat is one less in comparison to the parameter set.
 | Subsets(Set) | Generates a list of subsets of the given set.
Inheritance Hierarchy
Object
SetUtil


CheckSupport Method (s, fsList, data)

CheckSupport Method (s, fsList, data)
Namespaces ► Association_mining ► SetUtil ► CheckSupport(Set, List<(Of <FrequentSet>)>, Database)
Chaecks the support of a given (frequent) set.
Declaration Syntax
C# Visual Basic Visual C++
public static long CheckSupport(
    Set s,
    List<FrequentSet> fsList,
    Database data
)
Public Shared Function CheckSupport ( _
    s As Set, _
    fsList As List(Of FrequentSet), _
    data As Database _
) As Long
public:
static long long CheckSupport (
    Set^ s,
    List<FrequentSet^>^ fsList,
    Database^ data
)
Parameters
s (Set)
The checked set
fsList (List <(Of < FrequentSet >)>)
Frequent set list
data (Database)
Database
Return Value
The support value of the set


GenerateCandidateSets Method (setList)

GenerateCandidateSets Method (setList)
Namespaces ► Association_mining ► SetUtil ► GenerateCandidateSets(List<(Of <Set>)>)
Generates candidate sets from a given list of sets.
Declaration Syntax
C# Visual Basic Visual C++
public static List<Set> GenerateCandidateSets(
    List<Set> setList
)
Public Shared Function GenerateCandidateSets ( _
    setList As List(Of Set) _
) As List(Of Set)
public:
static List<Set^>^ GenerateCandidateSets (
    List<Set^>^ setList
)
Parameters
setList (List <(Of <Set>)>)
List of sets
Return Value
Sets that will possibly be frequent sets


GenerateRules Method (MainForm, data, Conclusions, frequentsets, minconf, mins, minf, maxanti)

GenerateRules Method (MainForm, data, Conclusions, frequentsets, minconf, mins, minf, maxanti)
Namespaces ► Association_mining ► SetUtil ► GenerateRules(frmMain, Database, List<(Of <Set>)>, List<(Of <FrequentSet>)>, Double, Double, Double, Double)
Generates rules from a list of frequent sets.
Declaration Syntax
C# Visual Basic Visual C++
public static SortableBindingList<Rule> GenerateRules(
    frmMain MainForm,
    Database data,
    List<Set> Conclusions,
    List<FrequentSet> frequentsets,
    double minconf,
    double mins,
    double minf,
    double maxanti
)
Public Shared Function GenerateRules ( _
    MainForm As frmMain, _
    data As Database, _
    Conclusions As List(Of Set), _
    frequentsets As List(Of FrequentSet), _
    minconf As Double, _
    mins As Double, _
    minf As Double, _
    maxanti As Double _
) As SortableBindingList(Of Rule)
public:
static SortableBindingList<Rule^>^ GenerateRules (
    frmMain^ MainForm,
    Database^ data,
    List<Set^>^ Conclusions,
    List<FrequentSet^>^ frequentsets,
    double minconf,
    double mins,
    double minf,
    double maxanti
)
Parameters
MainForm (frmMain)
Main program form
data (Database)
Database
Conclusions (List <(Of <Set>)>)
Conclusion list
frequentsets (List <(Of < FrequentSet >)>)
List of frequent sets
minconf (Double)
Minimal confidence
mins (Double)
Minimal confirmation-s
minf (Double)
Minimal confirmation-f
maxanti (Double)
Maximal anti-support
Return Value
A list of rules


GenerateTransitionVector Method (n)

GenerateTransitionVector Method (n)
Namespaces ► Association_mining ► SetUtil ► GenerateTransitionVector(Int32)
Generates a Johnson code transition vector used to find all subsets.
Declaration Syntax
C# Visual Basic Visual C++
public static int[] GenerateTransitionVector(
    int n
)
Public Shared Function GenerateTransitionVector ( _
    n As Integer _
) As Integer()
public:
static array<int>^ GenerateTransitionVector (
    int n
)
Parameters
n (Int32)
The number of items in the set to look for subsets
Return Value
An array of transition positions


HasDistinctTypes Method (s)

HasDistinctTypes Method (s)
Namespaces ► Association_mining ► SetUtil ► HasDistinctTypes(Set)
Checks if all the items in the given set are of different types.
Declaration Syntax
C# Visual Basic Visual C++
public static bool HasDistinctTypes(
    Set s
)
Public Shared Function HasDistinctTypes ( _
    s As Set _
) As Boolean
public:
static bool HasDistinctTypes (
    Set^ s
)
Parameters
s (Set)
Primary set
Return Value
True if none of the items of the items in the set are of the same attribute type


ParseEvidence Method (r)

ParseEvidence Method (r)
Namespaces ► Association_mining ► SetUtil ► ParseEvidence(Rule)
Transform the rules evidence from set form to a string.
Declaration Syntax
C# Visual Basic Visual C++
public static string ParseEvidence(
    Rule r
)
Public Shared Function ParseEvidence ( _
    r As Rule _
) As String
public:
static String^ ParseEvidence (
    Rule^ r
)
Parameters
r (Rule)
Rule which evidence will be parsed
Return Value
A string representing the rules evidence


ParseHipothesis Method (r)

ParseHipothesis Method (r)
Namespaces ► Association_mining ► SetUtil ► ParseHipothesis(Rule)
Transform the rules hipothesis from set form to a string.
Declaration Syntax
C# Visual Basic Visual C++
public static string ParseHipothesis(
    Rule r
)
Public Shared Function ParseHipothesis ( _
    r As Rule _
) As String
public:
static String^ ParseHipothesis (
    Rule^ r
)
Parameters
r (Rule)
Rule which hipothesis will be parsed
Return Value
A string representing the rules hipothesis


ParseSet Method (s)

ParseSet Method (s)
Namespaces ► Association_mining ► SetUtil ► ParseSet(Set)
Transform from set form to a string.
Declaration Syntax
C# Visual Basic Visual C++
public static string ParseSet(
    Set s
)
Public Shared Function ParseSet ( _
    s As Set _
) As String
public:
static String^ ParseSet (
    Set^ s
)
Parameters
s (Set)
Return Value
A string representing the set


SubsetMinusOne Method (set)

SubsetMinusOne Method (set)
Namespaces ► Association_mining ► SetUtil ► SubsetMinusOne(Set)
Generates a list of subsets with a count htat is one less in comparison to the parameter set.
Declaration Syntax
C# Visual Basic Visual C++
public static List<Set> SubsetMinusOne(
    Set set
)
Public Shared Function SubsetMinusOne ( _
    set As Set _
) As List(Of Set)
public:
static List<Set^>^ SubsetMinusOne (
    Set^ set
)
Parameters
set (Set)
Set to create a subset from
Return Value
A list of subsets that have one item less than the primary set


Subsets Method (s)

Subsets Method (s)
Namespaces ► Association_mining ► SetUtil ► Subsets(Set)
Generates a list of subsets of the given set.
Declaration Syntax
C# Visual Basic Visual C++
public static List<Set> Subsets(
    Set s
)
Public Shared Function Subsets ( _
    s As Set _
) As List(Of Set)
public:
static List<Set^>^ Subsets (
    Set^ s
)
Parameters
s (Set)
Primary set
Return Value
A list of subsets


SortableBindingList Class

SortableBindingList<(Of <T>)> Class
Namespaces ► Association_mining ► SortableBindingList<(Of <T>)>
A sortable list that can be bound to a DataGrid, DataGridView, DataSet or DataTable component
Declaration Syntax
C# Visual Basic Visual C++
public class SortableBindingList<T> : BindingList<T>
Public Class SortableBindingList(Of T) _
    Inherits BindingList(Of T)
generic<typename T>
public ref class SortableBindingList : public BindingList<T>
Generic Template Parameters
T
Type of elements held in the list
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SortableBindingList<(Of <T>)>SortableBindingList<(Of <T>)>New()() | Default constructor.
 | SortableBindingList<(Of <T>)>SortableBindingList<(Of <T>)>New(IEnumerable<(Of <T>)>) | Constructor.
 | ApplySortCore(PropertyDescriptor, ListSortDirection) | Sorts the list. (Overrides BindingList <(Of <T>)>.ApplySortCore(PropertyDescriptor, ListSortDirection).)
 | IsSortedCore | Tells if the list is sorted. (Overrides BindingList <(Of <T>)>.IsSortedCore.)
 | RemoveSortCore()() | (Overrides BindingList <(Of <T>)>.RemoveSortCore()().)
 | SortDirectionCore | The current sorting direction of the list. (Overrides BindingList <(Of <T>)>.SortDirectionCore.)
 | SortPropertyCore | The sort property definition. (Overrides BindingList <(Of <T>)>.SortPropertyCore.)
 | SupportsSortingCore | Defines the ability of the list to be sorted. (Overrides BindingList <(Of <T>)>.SupportsSortingCore.)
Inheritance Hierarchy
Object
 | Collection <(Of <T>)>
 |  | BindingList <(Of <T>)>
 |  |  | SortableBindingList<(Of <T>)>


SortableBindingList Constructor

SortableBindingList<(Of <T>)> Constructor
Namespaces ► Association_mining ► SortableBindingList<(Of <T>)> ► SortableBindingList<(Of <T>)>SortableBindingList<(Of <T>)>New()()
Members
Icon | Member | Description
 | SortableBindingList<(Of <T>)>SortableBindingList<(Of <T>)>New()() | Default constructor.
 | SortableBindingList<(Of <T>)>SortableBindingList<(Of <T>)>New(IEnumerable<(Of <T>)>) | Constructor.


SortableBindingList Constructor

SortableBindingList<(Of <T>)> Constructor
Namespaces ► Association_mining ► SortableBindingList<(Of <T>)> ► SortableBindingList<(Of <T>)>SortableBindingList<(Of <T>)>New()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public SortableBindingList()
Public Sub New
public:
SortableBindingList ()


SortableBindingList Constructor (enumerable)

SortableBindingList<(Of <T>)> Constructor (enumerable)
Namespaces ► Association_mining ► SortableBindingList<(Of <T>)> ► SortableBindingList<(Of <T>)>SortableBindingList<(Of <T>)>New(IEnumerable<(Of <T>)>)
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public SortableBindingList(
    IEnumerable<T> enumerable
)
Public Sub New ( _
    enumerable As IEnumerable(Of T) _
)
public:
SortableBindingList (
    IEnumerable<T>^ enumerable
)
Parameters
enumerable (IEnumerable <(Of <T>)>)


ApplySortCore Method (prop, direction)

ApplySortCore Method (prop, direction)
Namespaces ► Association_mining ► SortableBindingList<(Of <T>)> ► ApplySortCore(PropertyDescriptor, ListSortDirection)
Sorts the list.
Declaration Syntax
C# Visual Basic Visual C++
protected override void ApplySortCore(
    PropertyDescriptor prop,
    ListSortDirection direction
)
Protected Overrides Sub ApplySortCore ( _
    prop As PropertyDescriptor, _
    direction As ListSortDirection _
)
protected:
virtual void ApplySortCore (
    PropertyDescriptor^ prop,
    ListSortDirection direction
) override
Parameters
prop (PropertyDescriptor)
direction (ListSortDirection)


IsSortedCore Property

IsSortedCore Property
Namespaces ► Association_mining ► SortableBindingList<(Of <T>)> ► IsSortedCore
Tells if the list is sorted.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool IsSortedCore{ get;}
Protected Overrides ReadOnly Property IsSortedCore As Boolean
protected:
virtual property bool IsSortedCore {
    bool get () override;
}


RemoveSortCore Method

RemoveSortCore Method
Namespaces ► Association_mining ► SortableBindingList<(Of <T>)> ► RemoveSortCore()()

[Missing <summary> documentation for M:Association_mining.SortableBindingList`1.RemoveSortCore]

Declaration Syntax
C# Visual Basic Visual C++
protected override void RemoveSortCore()
Protected Overrides Sub RemoveSortCore
protected:
virtual void RemoveSortCore () override


SortDirectionCore Property

SortDirectionCore Property
Namespaces ► Association_mining ► SortableBindingList<(Of <T>)> ► SortDirectionCore
The current sorting direction of the list.
Declaration Syntax
C# Visual Basic Visual C++
protected override ListSortDirection SortDirectionCore{ get;}
Protected Overrides ReadOnly Property SortDirectionCore As ListSortDirection
protected:
virtual property ListSortDirection SortDirectionCore {
    ListSortDirection get () override;
}


SortPropertyCore Property

SortPropertyCore Property
Namespaces ► Association_mining ► SortableBindingList<(Of <T>)> ► SortPropertyCore
The sort property definition.
Declaration Syntax
C# Visual Basic Visual C++
protected override PropertyDescriptor SortPropertyCore{ get;}
Protected Overrides ReadOnly Property SortPropertyCore As PropertyDescriptor
protected:
virtual property PropertyDescriptor^ SortPropertyCore {
    PropertyDescriptor^ get () override;
}


SupportsSortingCore Property

SupportsSortingCore Property
Namespaces ► Association_mining ► SortableBindingList<(Of <T>)> ► SupportsSortingCore
Defines the ability of the list to be sorted.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool SupportsSortingCore{ get;}
Protected Overrides ReadOnly Property SupportsSortingCore As Boolean
protected:
virtual property bool SupportsSortingCore {
    bool get () override;
}


SupportComparer Class

SupportComparer Class
Namespaces ► Association_mining ► SupportComparer
Allows to compare support values in ore=der to sort them in descending order.
Declaration Syntax
C# Visual Basic Visual C++
public class SupportComparer : IComparer<long>
Public Class SupportComparer _
    Implements IComparer(Of Long)
public ref class SupportComparer : IComparer<long long>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SupportComparerSupportComparerNew()() |
 | Compare(Int64, Int64) |
Inheritance Hierarchy
Object
SupportComparer


SupportComparer Constructor

SupportComparer Constructor
Namespaces ► Association_mining ► SupportComparer ► SupportComparerSupportComparerNew()()
Initializes a new instance of the SupportComparer class.
Declaration Syntax
C# Visual Basic Visual C++
public SupportComparer()
Public Sub New
public:
SupportComparer ()


Compare Method (x, y)

Compare Method (x, y)
Namespaces ► Association_mining ► SupportComparer ► Compare(Int64, Int64)

[Missing <summary> documentation for M:Association_mining.SupportComparer.Compare(System.Int64,System.Int64)]

Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    long x,
    long y
)
Public Function Compare ( _
    x As Long, _
    y As Long _
) As Integer
public:
virtual int Compare (
    long long x,
    long long y
) sealed
Parameters
x (Int64)
y (Int64)
Return Value

[Missing <returns> documentation for M:Association_mining.SupportComparer.Compare(System.Int64,System.Int64)]


frmMain.ThreadCallback Delegate

frmMain..::ThreadCallback Delegate
Namespaces ► Association_mining ► frmMain ► frmMain..::ThreadCallback
A delegate used invoke functions without parameters by a background thread.
Declaration Syntax
C# Visual Basic Visual C++
private delegate void ThreadCallback()
Private Delegate Sub ThreadCallback
private delegate void ThreadCallback ()


Namespaces

Namespaces
Namespaces