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Altera Quartus
• Narzędzie projektowe dla FPGA I CPLD
• Umożliwia: 

– wprowadzenie projektu, 
– syntezę logiczną i symulację funkcjonalną, 
– przydział do układów logicznych i ich łącznie,
– symulację czasową,
– analizę czasową, 
– zarządzanie użyciem mocy i 
– programowanie układu FPGA
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Altera Quartus

• Używamy (2015/2016) QUARTUS wersji 13.0 
sp1 gdyż współpracuje z symulatorem Altera 
University  Program

• Możliwość darmowego pobrania programów 
(cele edukacyjne) ze strony altera.com
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Quartus interfejs użytkownika

• Okno główne: pliki, raporty , inne okna
• Projekt nawigator: hierarchia, pliki projektu, 

skróty komend
• Okno statusu: status przetwarzania  zadań
• Okno komunikatów: informacje, błędy, 

ostrzeżenia
• Dynamicznie zmieniające się menu
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Quartus okno główne
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Projekt w Quartus

Praca zorganizowana w ramach projektów.
Projekt składa się z:
• plików projektowych i bibliotek,
• informacji o parametrach i  ograniczeniach,
• hierarchii projektu i informacjach o 

wydaniach.
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Etapy procesu projektowania w PLD 

1. Wprowadzanie projektu
– Schemat – edytor blokowy
– Język definiowania sprzętu HDL
– Formaty reprezentacji projektu w systemach EDA

2. Symulacja na poziomie przesłań międzyrejestrowych   RTL 
(czy projekt poprawny logicznie?)
– weryfikacja logiczna modelu bez opóźnień

3. Synteza (przydział elementów logicznych modelu do 
standardowych elementów)
– minimalizacja modelu logicznego
– optymalizacja modelu logicznego
– przydział elementów logicznych do podstawowych elementów 

składowych układu cyfrowego
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Etapy procesu projektowania dla PLD

4. Umieszczanie i łączenie (moduły ang. fitter router)
– przydział elementów logicznych do jednostek logicznych sprzętu 
– uwzględnienie wprowadzonych ograniczeń na realizację projektu 
– realizacja połączeń

5. Analiza czasowa (czy spełnione są ograniczenia czasowe?):
1. Badanie, optymalizacja  i prezentacja efektywności czasowej
2. sprawdzanie i informowanie o przekroczeniach ograniczeń czasowych

6. Symulacja czasowa:
– Sprawdza poprawność czasową logiki
– Korzysta z listy połączeń uwzględniających czas
– Wymaga wektorów wymuszeń na wejściach układu

7. Programowanie i badanie sprzętu
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Podstawowe działania (1)

TWORZENIE NOWEGO PROJEKTU 
• File> New Project

– katalog, 
– nazwa projektu, 
– nazwa elementu najwyższego poziomu w hierarchii 

projektu
– dołączenie plików projektu (np. plików komponentów 

biblioteki)
– określenie układu docelowego - EP2C35F672C6 dla DE2, 

EP2C70F896C6 dla DE2-70 
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Tworzenie nowego projektu za pomocą kreatora 
(katalog, nazwa, jednostka główna)
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Tworzenie nowego projektu za pomocą kreatora 
projektu
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UWAGA: DLA DE2 EP2C35F672C6 , DLA DE2-70 EP2C70F896C6



Tworzenie nowego projektu za pomocą kreatora
pliki schematu blokowego

VHDL, DE2, Quartus 12



Schemat blokowy –
umieszczanie podstawowych elementów logicznych 1
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Schemat blokowy –
umieszczanie podstawowych elementów logicznych 2
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Schemat blokowy –
zapis pliku w ramach projektu
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Wprowadzenie powiązań sygnałów i 
wyprowadzeń układu FPGA
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Przykładowe przyporządkowania sygnałów podłączonych do elementów  płytki do 
wyprowadzeń układu FPGA (różne wersje układów). Pozostałe informacje w 
plikach DE2_pin_assignments.csv, DE2_70_pin_assignments.csv



Wprowadzenie powiązań sygnałów 
układu i wyprowadzeń układu 

FPGA

• Kroki realizowane w Assignment editor opisano na 
kolejnych stronach

• Wg podręcznika: Quartus II Introduction                                                        
Using Schematic Designs 

VHDL, DE2, Quartus 17



1. wybrać: Assignments > 
Assignment Editor
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W rozwijanym menu Category wybrać All. 
Wbrać przycisk <<new>> w lewym górnym rogu okna tworząc nowy wpis 
w tabeli. Wybrać (dwuklik) pole w kolumnie oznaczonej nagłówkiem To 
dla uzyskania przycisku Node Finder. Po wybraniu przycisku pojawi się 
okno jak na poniższym rysunku:
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W oknie filtru wybrać: Pins: all
Pojawiające się w oknie Nodes found nazwy wyprowadzeń układu  skopiować 
strałką do okna Selected Nodes. Po potwierdzeniu OK wybrane sygnały pojawią 
się w kolumnie To w  Assignment Editor.



Wybranie (dwuklik) w Assignment Editor pola na prawo od 
nazwy sygnału w kolumnie Assignment Name spowoduje 
pojawienie się poniższego menu w którym wpisując pierwszą 
literę nazwy L należy znaleźć i wybrać opcję Location (Accepts 
wildcards/groups). ( należy powtórzyć dla każdego sygnału ze 
schematu uzyskując Location w kolumnie Assignment Name)
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W odpowiadjącej sygnałowi kolumnie Value należy wpisać 
(uzyskany np. z pliku DE2_pin_assignments.csv
lub DE2_70_pin_assignments.csv) opis wyprowadzenia układu 
FPGA do którego chcemy  podłączyć sygnał projektowanego 
urządzenia.
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Zamykając okno Assignment Editor powodujemy zapis przyporządkowań do 
pliku. 



Format pliku przyporządkowań (*.QSF) sygnałów 
projektu do wyprowadzeń układu FPGA jest pokazany 
poniżej. Ten plik tekstowy można przygotować również 

poza programem Quartus i wczytać opcją Import 
Assignments.
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set_location_assignment PIN_N26 -to b //b podłaczono do SW1
set_location_assignment PIN_P25 -to c //c  podłaczono do SW2
set_location_assignment PIN_AE22 -to y0 //y0 podłaczono do LEDG0
set_location_assignment PIN_AF22 -to y1 //y1 podłaczono do LEDG1
set_location_assignment PIN_W19 -to y2 //y2 podłaczono do LEDG2
set_location_assignment PIN_N25 -to a //a podłaczono do SW0



Kompilacja projektu – analiza wejścia, synteza i 
optymalizacja  modelu logicznego, przydział do sprzętu, asemblacja, 

analiza czasowa 
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Symulacja - Altera U.P. Simulator

• File>Open Project
• File>New simulation 

Input File
• Edit >Insert > Insert 

Node or Bus 
– Node Finder 
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Podstawowe działania - symulator
Definiowanie wektora testowego: zbioru sygnałów, 

okresu symulacji i wymuszeń: Altera U.P. Simulator
• Przydatne opcje:

– Edit> End time
– View>Fit in window
– Edit>Insert Node or Bus Node  
– View>Snap to grid
– Selection Tool – ikona w kształcie strzałki
– Waveform editing Tool – ikona ze zmieniającym się stanem 

magistrali
– Edit>Value - edycja stanu wymuszenia 
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Symulacja - Altera U.P. Simulator
Użyteczne opcje:
• Edit > Set End Time 
• Edit > Grid Size
• Edit > Snap to Grid
• Edit > Snap to Transition
Przygotowanie i kroki symulacji:
• Assign > Simulation Settings – okreslenie pliku 

wektorów testowych oraz typu symulacji

• Processing > Generate Simulation Netlist
• Processing > Start Simulation
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Symulacja - Altera U.P. Simulator

• Wyniki symulacji widoczne w Simulation Waveform Editor
• Szersze informacje na temat symulacji i edycji pliku 

wektorów testowych w: 
• Introduction to Simulation of VHDL Designs:  Altera

corporation University Program May 2011
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Przykłady symulacji –
symulacja funkcjonalna logika dzialania
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Przykłady symulacji –
symulacja czasowa - realizacja w sprzęcie
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Przykłady symulacji –
symulacja czasowa (powiększenie)
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Podstawowe działania ALTERA
• Programowanie i konfiguracja FPGA
Tryb: JTAG – ładowanie danych konfiguracyjnych układu bezpośrednio do 

FPGA, pozostają do wyłączenia zasilania. Do programowania w tym trybie: 
przełącznik trybu programowania płyty DE2 w stan RUN

– Tools>Programmer 
– Hardware Setup >  USB-blaster 
– Korzystamy z *.sof (SRAM object file) (Add file)
– Ustawienie przełącznika DE2 w stan RUN 
– Program/Configure
– Start
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Programowanie FPGA
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Tools/Programmer ; Wykorzystujemy interfejs USB-Blaster



Podstawowe działania dla VHDL(1)
• Nowy plik VHDL:

– File>New>VHDL
– okreslenie nazwy: File>Save As > Box Add file to current 

project
• Umieszczanie wzorców elementów w pliku VHDL:

– Edit>Insert Template>VHDL

• Dodawanie/usuwanie  plików do/z projektu:
– Assignments> Settings> Files
– Project> Add/Remove Files in Project
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Podstawowe działania VHDL (2)
• Przydział sygnałów do wyprowadzeń (pinów) 

programowanego układu FPGA:
– Assignments> Import Assignments
– Wybrać plik DE2_pin_assignments.csv (właściwy dla 

wykorzystywanej karty)
– wymagane oznaczenia sygnałów w projekcie zgodne z

standardowymi (zawartymi w pliku) nazwami 
elementów podłączonych do pinów (nóżek) 
programowanego układu

• Kompilacja:
– Processing>Start Compilation
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Polecane źródła informacji na temat DE2 i 
Quartus

• Prezentacje na temat podstaw korzystania z Quartus
– Quartus II Introduction Using VHDL Design
– Introduction to Simulation of VHDL Designs:  Altera corporation University Program 

May 2011

Oprogramowanie dostępne w celach edukacyjnych na 
www.altera.com w sekcji Altera University Program Design 
Software

• Podręcznik użytkownika płyty DE2
– DE2 Development and Education Board User Manual 
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CLK

czas_p

czas_c

czas_z

przycisk

Entity : przejscie
Architecture: przejscie_arch

Sreg0

cp

zp

cs

ps

zs

start_p

start_z

start_c

S1
/00001/

S2
/00010/

S3
/00100/

S4
/01000/

S5
/10000/

start

start='1'

zs<='1';
cs<='0';
ps<='0';
zp<='0';
cp<='1';

zs<='1';
cs<='0';
ps<='0';
zp<='0';
cp<='1';

przycisk='1'

start_p<='1';start_p<='1';

czas_p='1'

start_c<='0';
zs<='0';
cs<='1';
ps<='0';
zp<='1';
cp<='0';

start_c<='0';
zs<='0';
cs<='1';
ps<='0';
zp<='1';
cp<='0';start_p<='0';

zs<='0';
cs<='0';
ps<='1';
zp<='0';
cp<='1';

start_p<='0';
zs<='0';
cs<='0';
ps<='1';
zp<='0';
cp<='1';

start_z<='0';
zs<='1';
cs<='0';
ps<='0';
zp<='0';
cp<='1';

start_z<='0';
zs<='1';
cs<='0';
ps<='0';
zp<='0';
cp<='1';

start_c<='1';start_c<='1';

czas_c='1'

start_p<='1';start_p<='1';

czas_p='1'
start_z<='1';start_z<='1';

czas_z='1'

start_p<='0';   
zs<='0';
cs<='0';
ps<='1';
zp<='0';
cp<='1';

start_p<='0';   
zs<='0';
cs<='0';
ps<='1';
zp<='0';
cp<='1';

Przekształenie grafu stanów 
w opis automatu w VHDL

library IEEE;
use IEEE.std_logic_1164.all;
use IEEE.std_logic_arith.all;
use IEEE.std_logic_unsigned.all;

entity przejscie is 
port (

CLK: in STD_LOGIC;
czas_c: in STD_LOGIC;
...

end przejscie;
architecture przejscie_arch of przejscie is
attribute enum_encoding: string;
type Sreg0_type is (

S1, S2, S3, S4, S5
);
attribute enum_encoding of Sreg0_type: type is

"00001 " & -- S1
...

signal Sreg0: Sreg0_type;
begin
Sreg0_machine: process (CLK)
begin
if CLK'event and CLK = '1' then

if start='1' then
...

end process;

-- signal assignment statements for combinatorial outputs
zs_assignment:
zs <= '1' when (Sreg0 = S1) else

...
end przejscie_arch;VHDL, DE2, Quartus



Przykładowe wyniki pracy: 
Symulacja pracy prostego procesora, 

zapis zawartości rejestru do pamięci adresowanej zawartością rejestru
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Implementacja VHDL i DE2 na laboratorium PTC, autor: student 3 roku 
informatyki PP 2010/2011


